Announcement

Collapse
No announcement yet.

Music Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Music Issues

    Let's just start off with an apology if this was already asked before. I only surfed the first few pages of this section. I'm also kinda new to this, so this might seem as a stupid question.
    And before anyone tells me "Read the guide!", I already did before posting this, so if I missed something, please point that out.
    I wanted to have changes in music a lot in an episode. For example, I'll have one type in the introduction, another in a spooky scene, another in a happy scene, etc. I think I've seen it in stories but I don't really remember, so I don't know if it's possible or not.
    I did this:
    volume music 0 3000 (for the music mus_hollywoodcrush_maintheme)
    @pause for a beat
    @pause for a beat
    @pause for a beat
    @transition fade out black 3
    INT. LAVISH ENTRY HALL2 -DAY
    music music_spooky
    volume music 80 3000

    But when I tested the scene, mus_hollywoodcrush_maintheme would just play again instead of music_spooky! I tried doing this:
    volume music 0 3000 (for the music mus_hollywoodcrush_maintheme)
    @pause for a beat
    @pause for a beat
    @pause for a beat
    music off
    @transition fade out black 3
    INT. LAVISH ENTRY HALL2 -DAY
    music music_spooky
    volume music 80 3000

    This time, when I tested it, the music stopped completely after the music off command and music_spooky didn't play. Are there any solutions, or is my idea just simply not possible?

  • #2
    I think this might help not for that to happen:

    @BACKGROUND (is placed here)

    music mus_hollywoodcrush_maintheme

    volume music 0 3000

    @pause for a beat

    @pause for a beat

    @pause for a beat

    @music off

    @transition fade out black 3

    INT. LAVISH ENTRY HALL2 -DAY

    music music_spooky

    volume music 80 3000

    @music off

    Hope this helped

    If not, don't worry about using this. I think fading volume/music will help you. Here's the thread to access: http://forums.episodeinteractive.com...g-music-sounds

    xxx

    Fantasia

    Comment


    • cass.episode
      cass.episode commented
      Editing a comment
      Thanks! I'll try that out in a bit and see if it works.

    • cass.episode
      cass.episode commented
      Editing a comment
      It didn't work! The script had an error in it when I added the @music off thing.
      I've tried every possible solution I could think of, it's frustrating! I even tried switching from music to sound, and even THAT didn't work!

    • Fantasia Episode
      Fantasia Episode commented
      Editing a comment
      Oh I'm so sorry! Kandy has just helped you

  • #3
    Remove the @ in front of music off

    Comment


    • #4
      Thank you all for the help! I discovered that using the music command with sounds actually works in this situation, so the problem is solved.

      Comment


      • Kandy
        Kandy commented
        Editing a comment
        you can also use

        sound sound_name_here

    • #5
      I am also having problems with this in certain scenes. I use the same code every single time but with certain files it just won't play. If I type music off then fade the music in volume music 100 1000 the music wont come on at all. if I remove the music off, the song from the previous scene will start playing in on the fade instead. I don't understand what's going on :S

      Comment


      • #6
        cass.episode myarmyofmonkeys : It's not confirmed, but there's probably a glitch where certain music files just won't play. As mentioned above, you can play it as a sound (which won't loop), or you'll just have to choose another file! There's nothing wrong with your code

        Comment


        • myarmyofmonkeys
          myarmyofmonkeys commented
          Editing a comment
          aha! Sorry I must have missed that post! I did end up playing another sound file and got it to work. I was so annoyed because the code worked in the previous scenes. Thanks

      • #7
        If I might input, I've actually had a ticket open that's been bumped up to Liz about this. I was using music_spooky as well and it wouldn't play in the app. I also noticed one time I had a choice where you'd pick your music, but one of the files I'd chosen wouldn't play. I replaced it with another file to check my code, and it worked fine.

        On one hand it makes me worried to publish a story with a file that doesn't work while testing, because it's hard to know if it'll work once published, but I'll post if I hear any word on the subject with my open ticket. I have yet to publish anything partially because of this (and I'm new and slow, but you get it).

        I'd say if you run into this problem, check with another sound file first to make sure your code is working, so that you know if it's your code or the music file itself that's glitching.

        Comment


        • cass.episode
          cass.episode commented
          Editing a comment
          Thank you! That's very helpful.
      Working...
      X