ANOTHER problem i can't explain

I have no error warnings, but for some reason the portal and my phone both just randomly skipped these commands, even when I try and rewrite them differenlty.

She walks off, they move to the layers wanted, but she skips moving spots, facing right, transitioning_stand_to_squat and the pause for 8, it just leaves a gap then suddnely appears. Feels like I’m going crazy

it works when I replace YOU with her double YOU2, anyone know why?

Why do you use the pause between transition and spot? The transition itself make like a pause. Maybe try removing it?

becuase that animation takes a long time, I always cut it as it makes her awkwardly stand there, and thats defo not the issue because i split all the animations and it still skipped, that script works just with different characters

I tried out your code and I was having different issues with it.

  1. The YOU character wasn’t changing size with what was set in the spot command, which is why I put a 0.1 pause in between.
  2. I changed Dani to layer 4, you may want to change it back if it causes issues with anything else.
  3. I separated out the cut and zoom, it’s not necessary, it’s just how I code.

If you replace your code with this, it should work as you intended:

@YOU walks to spot 0.974 232 102 in zone 1 in 1 THEN pause for 0.1 THEN YOU spot 1.505 84 -131 in zone 2 at layer 5
@DANI spot 1.505 251 -201 in zone 2 at layer 4 AND DANI faces left AND DANI starts idle_armscrossed_neutral_loop

@cut to zone 2
@zoom reset

@YOU faces right AND YOU starts transition_stand_to_squat_neutral THEN pause for 0.8 THEN YOU spot 1.505 81 -207 in zone 2 AND YOU is idle_shiftweight_neutral_loop

I ended up just using her duplicate for a moment and then changing her back which worked easy, I reworded the script a few ways and put pauses between things but for me no matter what she wouldn’t change size, it’s happened a few times over my script it’s pretty frustrating

I’d heard of other people having this issue but never twigged that it was because they were moving the character AND changing the size at the same time.

Definitely a bug at Episodes end. The walk command must overshoot the time allocated so when you spot it at a different size immediately after moving, the walk command overrides it with it’s own size (but weirdly, not location). So only 2 solutions, the one you found, using a different character, or putting a pause between the walk and spot commands.

I’ve never come across it before, myself, because I’ve never changed the characters size when moving them. Up to this point, I’ve only ever moved them and changed the zoom level instead.


usually i would do that but it was very specificly needed to be done how i did it lol i couldn’t just move the zoom or add much else otherwise there would be a pause. I always use commands like this never usually have a problem until recently, where I’ve had a lot of random problems.