Anyone know what "too many values to unpack" mean?

I’m trying to have my character walk out of the screen to zone two, but i cant use the exit command because my camera is zoomed in so the character will increase in size yk?

and when i tell them to use the walks to spot command the script tells me there’s too many values to unpack ;-;

this is the script issue

Screenshot 2023-04-15 10.38.00 PM

I also tried using “@DAD exits left AND AVERY walks to spot 0.966 159 in zone 2”
and the “then” too but it also didn’t work.

Try to zoom out on your phone or the desktop preview then find the spot that is out of view from the zoom in your script then once you find the spot for DAD say:
@DAD walks to spot
Then this:
@remove DAD

i think the issue is with this line, not the dad line.

&AVERY walks to spot 0.966 159 in zone 2

Did you want avery to walk out of the zone? And is she the one that appears large after exiting?

It should be
@AVERY walks to spot

yes, avery is supposed to walk out of frame into the other zone, and i tried to have her do that but it says that

and they both appear large when they exit but my biggest issue is with avery because she’s supposed to enter the building

I’d try to replace the

And if Avery appears large once she exits… I’d place her somewhere off frame then have her removed. You’ll have to do spot directing for the exiting.

I tried with the @ as well, but the script just doesn’t read the line. instead as it says “too many values to unpack” the script has dad leaves thru the left and avery just stands there without doing anything

Hmm… are you sure that’s what’s causing the warning? Try clicking on the warning. Also you’re missing something Z during the spot direction for Avery.
@AVERY walks to spot x y z

You’re missing the 2nd coordinate.
@ or &CHARACTER walks to spot 1.280 234 123 in zone 1 in 2

1 Like

yes it was, but guess what? i tried to move her out of frame but not too far and it worked.

i dunno why the script had an issue with the @AVERY walks to spot 0.966 159 in zone 2 line
but i changed her spot to @AVERY walks to spot 0.966 39 109 in zone 2 and it went thru lolll.

thank you sm for the help though :heavy_heart_exclamation: , i never seen this type of error b4.

1 Like

i noticed that too i dunno why the first spot didnt have three numbers like that. but i changed the spots to @AVERY walks to spot 0.966 39 109 in zone 2.

thank you!!

1 Like

It happens :joy: but I’m glad it worked! :heart:

1 Like