Bug with overlays


#1

I have a weird problem with my overlays where they’re not showing up in the spot where they’re supposed to. For example, in the code, I have an overlay that is supposed to ‘shifts to -361 -4’. But when I look at it in the app, it says that it ‘shifts to -675 9’.

I have no idea why it does this or what’s going on and I’ve been searching for a solution, but I can’t find one.


#2

Could you post the coding of the overlay please


#3

Are you in zone 2 or 3?
You’ll always need to add the zone to your shifts command if you’re not in zone 1 (e.g @overlay OVERLAY shifts to -361 -4 in zone 2).
If it’s not that, maybe post a photo of your script? I personally haven’t had any glitches with overlays recently.


#4

INT. BLACK - NIGHT
@transition fade out 2.0
INT. ROYALBATH with TABLE_WITH_ BREAD with TABLE_WITH_CANDLE with TABLE_WITH_ROSES with TABLE_WITH_WINE
&overlay TABLE_WITH_WINE shifts to -361 -4
&overlay TABLE_WITH_WINE scales to 0.786 0.786
&overlay TABLE_WITH_ BREAD shifts to -225 -57
&overlay TABLE_WITH_ BREAD scales to 0.572 0.572
&overlay TABLE_WITH_ROSES shifts to 366 084 in zone 3
&overlay TABLE_WITH_ROSES scales to 0.762 0.762
&overlay TABLE_WITH_CANDLE shifts to 228 -90 in zone 3
&overlay TABLE_WITH_CANDLE scales to 0.701 0.701
&cut to zone 2
&HARMONY spot 1.164 159 -131 in zone 2 AND HARMONY is sleep_sit_neutral_loop
@transition fade in black
@zoom on 566 0 to 224% in 2

^ There you go.


#5

Yeah, I added that (except for the ones in zone 1), but it’s still not working.


#6

Try this:
INT. ROYALBATH with TABLE_WITH_BREAD to .572 -225 -57 in zone 1 with TABLE_WITH_CANDLE to to .701 228 -90 in zone 3 with TABLE_WITH_ROSES to .762 366 084 ??- I think this could give you an issue? I’m guessing this is supposed to be 84 in zone 3 with TABLE_WITH_WINE to .786 -361 -4 in zone 1

Since you’ve already added them to the background, it might be neater if you add the commands there too. Also- that table_with_roses spot looks a bit off (084).
Also when you place them, make sure you’re in the actual zone (like don’t just zoom out from zone 1, adjust an overlay in zone 3 and say it’s in zone 3 if that makes sense).


#7

Okay, I tried it, but it still is making the same mistake. The overlays aren’t going to where the script tells them to go, they’re just going off screen for some reason.


#8

Are you in the correct zone when you place them? Like are you actually in zone 3? Or are you zooming out. Are any of them in the right spot?


#9

Because I literally have a scene with 40 overlays in it right now and none of them are glitching :woman_shrugging:t4: but of course, not everyone gets all the glitches lol so there very well could be an issue with your device but it’s usually a coding issue.


#10

I don’t understand what you mean by zooming out though.


#11

They’re in the right spot when I place it in the app, it just suddenly changes.