Buying No Ads and Unlimited Passes Won’t Work

I have been buying the no ad and unlimited passes bundle for over a year and a half now. Every time it has worked. This month when I went to buy it, it started glitching out. Every time I go to buy it and click on it, the loading screen pops up for a split second. Also it sometimes does this:

I have been trying it for a few days and I have contacted customer support. Unfortunately, nothing has worked. I don’t know if this is just happening to me or if it is an Episode problem.

Okay, I’m a certified iOS technician, and here’s what I’d recommend (go in order of the things listed, and if something doesn’t work, move on to the next thing):

  1. Check for any Episode updates. If there is one, update the app.
  2. Check to make sure the card that you’re using to make the purchase is valid.
  3. Reboot your device.
  4. Log out of your Episode account and log back in.
  5. Delete the Episode app and re-download it (you should log back into your account afterwards).

If none of these things work, then it’s most likely a glitch that Episode will have to fix (so be on the lookout for their next update). If you’ve contacted customer support, that’s all you can do for now. You might have to just watch some adds for a few weeks until they fix it.

Moved to Report a Bug Mobile App. Make sure to check out our Forum Tutorial for more info about creating topics, and feel free to PM me if you’ve got questions. :wink:

I figured it out. I just had to go buy it on a different device on the same account.