Can anyone help please?

Could anyone help me please? It would be much appreciated.![image|374x500](upload://na


I think you need to delete the bracket on line 1684 and put it right before the else

I’m not sure, but I would try

can you post and paste script here?

There is no If.
It ALWAYS has to be If/else

Oh, i found the If

Maybe you placed your else too late? Because there is a choice between if and else, which isn’t in brackets.

1 Like

Brackets are messed up but dressing game should be outside if/else anyway.

1 Like

Alright, so I typed out a makeshift script similar to yours to see what the problem was, and I think I found the problem? This is my script after I edited and tested it (it’s an oversimplified version, took me like 1 minute to type out):

label dressinggame_1
if (TAPABLE is "yes"){

choice (OUTFIT_1)
"outfit 1"{
@pause for 1
}"outfit 2"{
@pause for 1

goto dressinggame_1

All I changed was:

  • removed bracket on line 1684
  • added bracket on line 1695, before “else”

The problem was that you closed the bracket on line 1684, even though it’s supposed to be closed on line 1696.
The “outfit confirmation” starting from line 1685 should still be enclosed in the brackets containing the
if (TAPABLE is "Yes.. lines of code.
When you put the bracket on 1684 to close the dressing game, it actually closed the overall bracket from the “if” code. This means that when you put the “else” after the outfit confirmation, the script got confused, because the “if” code should already be ended and it had not idea what the “else” was doing there lol

It worked in my script but tell me if it still doesn’t work, I’ll try to figure out any other possible errors (:


Thank you so much, I’ve just tried it and it worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.