Cant figure out my tappables?

check if your overlays do not overlap - because if they do overlay you will tap always the overlay on top - the empty space around the overlays counts too as tappable space - so in preview tapp the button “change overlay” you should see the frames around the overlays - and they should not overlap each other - is this OK?

1 Like

Yeah and none of them do because I designed them, so I made sure they didn’t have a hurdenous white outer box

basically yes the code with the point number shows how many readers really got

  • the maximum you must write manually - that means you must count it in every chapter how many points maximally reader could have got and update it each chapter
1 Like

Got it ok that makes sense, thank you for helping me fix that now onto the tappable overlays lol

honestly I cant find problem in the code itself.

Sometimes some overlays are corrupted and do not react on tapp …

So you can chack it by keeping the code principle but for testing exchange for some other overlays.

Or what I also do . - if you replace word tappable for choice (and add narrator where needed) ut will turn out to normal choice - if that will work and send reader where it should go, the problem is not lin lables or tappable coding itself but in the overlays

  1. name of overlay is not the exact same as in the tappable code so it is not actually connected with the overlay (unfortunatelly such typo doesnt create any error message)
  2. overlaping overlays
  3. corrupted overlays

also try to refresh your beowiser if its not just some portal bug.

Yeah I had this problem in another one of my tappable overlays but the reason was I didn’t have brackets and stuff where they needed to be I think its the same problem because they all are able to be tapped on . I just don’t know where those brackets and stuff would go im new to coding on my own and with this much

as said I dont see coding mistake (might be there but I dont see one) the bracket seems to me fine.

Do you have any error messages?

It would look something like this, but going all the way through the minimum and maximum number of points.

if (POINT = 0) {

You have 0 points.

] elif (POINT = 1) {

You have 1 point.


Yeah ill do the easier way lol

In terms of the error, I might suggest checking it in the app to see if it works there. Sometimes things will work in the app/portal and not work in the other. There also may be some hint in the form of an error message regarding what the problem with the overlay could be.

there is a newer method with the character number so you do not have to write the long if/ elif/else in case the reader has like 50 points

1 Like

so I did the test with changing it to choice since I do not have your overlays and it works its just coded so I had to tapp 2 times to I am done to get from 1 point to another - I guess this is the problem since you most likely havent tried to tap 2 times on I AM DONE

To solve this under each point instead of
goto Points_1

just write

goto Points_1

I hope this will solve your issue

Thank you but I solved it, and it works perfectly thank you for all you knowledge and help tho!!

lol OK what was the problem then?

goto Im_done
goto Romance_1
goto Friendship_1
goto Ruler_1
goto Magic_1
goto Strength_1
goto Family_1
I didn’t have this at all in the right area lol

lol OK great that you solved it!!

1 Like

well THAT is extremely convenient

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.