Character glides instead of walking


#1

&CHAR1 enters from left to screen center
@pause for 0.4
@CHAR2 enters from left to screen left
&pan to zone 2 in 3
@CHAR1 walks to screen center in zone 2 in 3 AND CHAR1 does it while walk_neutral AND CHAR2 walks to screen left in zone 2 in 3

What is the problem with my coding?
CHAR1 is gliding from where the text is bold instead of walking…


#2

You’re not giving CHAR1 enough time to walk to screen center, because you’re pausing for 0.4 seconds, then have CHAR2 walk to screen left. It takes CHAR2 less time to walk to screen left than it does for CHAR1 to walk to screen center. Try putting another @pause for 0.4 after CHAR2 enters

&CHAR1 enters from left to screen center
@pause for 0.4
@CHAR2 enters from left to screen left
@pause for 0.4
&pan to zone 2 in 3
@CHAR1 walks to screen center in zone 2 in 3 AND CHAR1 does it while walk_neutral AND CHAR2 walks to screen left in zone 2 in 3


#3

I there a way to make it look smooth?
CHAR1 is now standing for 0.4, and I just want it to continue…


#4

I found the solution:
&CHAR1 enters from left to screen center
@pause for 0.4
@CHAR2 enters from left to screen left
&pan to zone 2 in 3
&CHAR2 walks to screen left in zone 2 in 3
@pause for 0.4
@CHAR1 walks to screen center in zone 2 in 3

Now it is almost smooth!


#5

You can try this:

&pause for 0.5 THEN CHAR2 enters from left to screen left THEN CHAR2 walks to screen left in zone 2 in 3
@CHAR1 enters from left to screen center THEN follow CHAR1 to screen center in zone 2 in 3


#6

Closing due to one month of inactivity :slight_smile:


#7