Character not showing up in script error

Welcome to my third script problem this week :sweat_smile:
I have a feeling it’s probably just a little problem I’m not seeing, but I have my character walk towards the camera so they block the characters, then rearrange the characters and have the character blocking the scene appear at the back, with a zoom so it looks like nothing has changed.
That sounds confusing, but here’s my script

@YOU walks to spot 7.417 169 -2996 in zone 1 in 3
&JACK spot 0.577 233 262 and JACK moves to layer 4 and JACK is idle
&AVA spot 0.577 72 261 and AVA moves to layer 4 and AVA is idle_armscrossed_neutral_loop
&AVA faces right
&WYATT spot 0.455 122 373 and WYATT moves to layer 2 and WYATT is idle_awkward_uneasy_loop
&WYATT faces right
&MAE spot 0.448 192 373 and MAE moves to layer 2 and MAE is idle_terrified_loop
&WESLEY spot 0.577 233 262 in zone 3
&PHOEBE spot 0.577 72 261 in zone 3
&BRAEDAN spot 0.455 122 373 in zone 3
&COOPER spot 0.455 192 373 in zone 3
@YOU spot 0.325 159 463 in zone 1 and YOU is idle
@zoom on 159 372 to 2350% in 0

So basically my character(YOU) is not showing up at 0.325 159 463, but staying at 7.417 169 -2996, or, actually, when I use the preview and look at the box at the bottom that tells you where the character is, its actually 7.417 159 463. So the scale isn’t changing.

I’m just super confused and I’ve tried everything I can think of so… help?

1 Like

I had the character at 7.417 169 -2996 before, and then later I put it as 0.325 159 463 but it’s not putting it at that smaller scale(that’s in the code I posted). When I tried to make it smaller and less high up, it didn’t change anything

Add this to the walking command:

@YOU walks to spot 7.417 169 -2996 in zone 1 in 3 THEN remove YOU

Explanation

The script doesn’t like when you respot a character immediately after they walk to a spot. So you have to remove them right after they walk for them to appear at the next spot.

1 Like

That worked, thank you!

1 Like

Yea but then there’s a random awkward pause after they walk.

They both worked, but the pause isn’t very long anyway

Closed: Marked as solved by @b.e.c.c.a :v: Thanks to @Pollexi & @Dara.Amarie for the assist :v: