Choices must follow dialogue, not a branch: Remembering choices

The script ->
label color_choice
ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold | What’s your favourite colour/color ?
| shadow:purple , color:lavender, bold | (It’ll matter later).

choice “Pink” {

    ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold |Thank you it'll matter later

gain color_pink

}
choice"Purple" {

    ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold | Thank you it'll matter later

gain color_purple

} choice"Blue" {

    ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold |Thank you it'll matter later

gain color_blue

} choice"Orange" {
ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold | Thank you it’ll matter later
gain color_orange

}choice “Green” {
ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold | Thank you it’ll matter later
gain color_green
} choice “Yellow” {
ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold | Thank you it’ll matter later
gain color_yellow
}

    ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold | Are you sure that your favourite colour/color

choice “Yes, I’ve chosen my favourite color/colour” {

    ZANELE (talk_agree_happy)
| shadow:purple , color:lavender, bold |Okay if you say so

} "No, I chose the wrong color/colour " { goto label color_choice

}

please help, sorry for the hassle.

Mind the spelling errors :sweat_smile:

Remove choice from:

You dont need to put the word choice before every choice!
It should look like this
choice
“Red” {
}
“Blue” {
}
“Green” {
}

Try it out

Sorry, I don’t want to ignorant especially when you’ve taken time to help me, but when I didn’t add choice to it it didn’t count and it wasn’t applied later to the if elif else situation. :slightly_smiling_face:

Sorry, I don’t want to ignorant especially when you’ve taken time to help me, but when I didn’t add choice to it it didn’t count and it wasn’t applied later to the if elif else situation. :slightly_smiling_face:

I believe you need to put dialogue before the actual choice and it isn’t necessary to put choice before every option :))

How did you code the if/ elif?
Since you have gains in each choice it shouldn’t be a problem but the word choice only needs to be at the beginning and not before every choice :slight_smile:

1 Like

This is how a simple choice looks. More info here: HOW TO: Simple Choices

When you’re testing your story (remembering past choices) test on the app. Do not forget to reset your flags (which are gains) to test other options. How to here: HOW TO: Reset Story Progress + Bonus Stuff :blob_sun:

1 Like

It worked thanks, I removed the choices as everyone who helped me said, all I had to do was reset my story progress :sweat_smile: . Thank you for your help. Again :joy:

1 Like

It’s okay it’s sorted out now, thank you for your help. :smile:

It’s okay it’s sorted out, thank you for your help :smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.