Directing Help: Script Error (Unable to find problem)

I need some help finding a problem in my code as I’ve tried reading over it to see whats wrong. Any help would be appreciated please :slight_smile:

@/ALISHA moves to layer 2 AND LANDON moves to layer 1 AND ALISHA walks to spot .698 188 250 in 1.5 AND ALISHA starts run_jog AND LANDON walks to spot .737 112 243 in 1.5 AND LANDON starts run_jog AND zoom on 594 279 to 136% in 1.5 AND overlay YELLOW AND GREY COUCH opacity 0 in 0

That ‘/’ between the @ and ALISHA isn’t there in script, I just don’t want to accidentally tag someone that isn’t there.

Anyway, the overlay name is correct and works just fine in the scene because opacity changes, and I even copy and pasted the name in there so it was correct.

In the walks to spot coding for both Landon and Alisha you need the zone too before the number of seconds.
and ALISHA walks to spot # # in zone # in # (number of seconds it takes) and ALISHA does it while animation_name

Also I would suggest not cramming everything on one line as it can get messy and then harder to figure errors when they occur.
You can put the zoom and overlay on a separate line above it using & instead of @ and it will work at the same time as the character walks.

Also I’m surprised you don’t have an issue with your overlay since you shouldn’t have the word “AND” in the name of it.

I didn’t think that was the reason, but I tried either way and it still came up with an error

Since I’m already in zone 2, spot placement defaults to zone 2 for the code. While that is a correct code, it doesn’t help me in this situation as it knows that the character needs to walk to that spot in that zone

Thank you though! :blush::blue_heart:

1 Like

What is the error you’re getting?

It says

@/CHARACTER moves to layer X

But from personal experience it can be anything in that line of code and it just chooses a random part to highlight.

I think it’s likely because of your overlay name since it has the word AND in it, it then thinks you’re coding a character. That’s the only thing I see wrong with that coding. :thinking:

I have to edit this: :joy: it doesn’t think it’s a character i don’t know why I said that but it reads it as if you’re using the code “AND” in general. Same case if you were to use the word “THEN” in the name. And it’s not what I see wrong in that coding. The coding is correct but it’s what I see can cause an error. (I need to go to bed :woman_facepalming:t3:, sorry)

Yep that’s what it is. Weird though since I’ve never heard that happen before

Thank you!!

1 Like

No problem! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.