Episode Studio (and anything besides the forum) not loading

I’m not even sure if I’m posting it in the right category but I made my account here like 20 minutes ago.

The problem is, nothing is loading and I’m not sure why. Other websites are loading and I’m getting irritated because I wanted to try writing stories myself.

What are you seeing instead of the pages? Can you include a screenshot? Thanks and welcome to the forums :smiley:

I see literally nothing: the page is just white. I already restarted my laptop and deleted browser cache,

What browser, links to the sites this is happening on and screenshots please, kthx.

https://home.episodeinteractive.com/studio and https://www.episodeinteractive.com/

Also tried with adblock off but it doesn’t make a difference

1 Like

I see you have some addons/plugins installed in the browser. Try disabling them and shift f5ing the pages

Strange. You did everything I could ask for. Only direction I can point you in is submitting a ticket to the support team. Sorry :disappointed:

I’ll wait until tomorrow and if it’s not working I’ll try submitting a ticket :frowning:

I suggest using Crome browser just for save sites without any ad blockers or other widgets, and install another browser for other stuff.

I don’t know why it is loading for ages. I can’t open a single episode! It doesn’t stop loading even after hours passed. I already updated the app, and I have my mobile data on.

I’m not sure what the problem was but it is working now :slight_smile: