Gains not working! HELP!

I don’t know what I’m doing wrong, but my gains don’t work.

label dressing_game

    EMMA (think_rubchin)
What should I wear to the meeting?

choice
“The dress that he sent”{

@EMMA is dustoff_neutral_loop
@EMMA changes into Julie-Meet

@EMMA is idle_shiftweight_neutral_loop

gain you_wore_the_dress

}
“My own dress”{

@EMMA is dustoff_neutral_loop
@EMMA changes into Julie-Meet2

@EMMA is idle_shiftweight_neutral_loop

}

if (you_wore_the_dress){

    VICTOR (talk_sit_crossarms_neutral)
You wore the dress. We're off to a good start here.

    EMMA (talk_sit_doubtful)
Umm..

readerMessage Congrats, you will now be able to unlock information which will prove useful!

}else{

    VICTOR (talk_sit_shrug_neutral)
You're a bit of a rebel, aren't you?

    EMMA (talk_sit_doubtful)
What do you mean?

    HERMAN (talk_sit_crossarms_neutral)
You didn't wear the dress.

readerMessage Uh-oh, you didn’t wear the dress, you won’t be able to unlock any extra information.

}

All right, I see you’re only showing a bit of the code but to solve your problem, I’d recommend this:

When you include a dressing game with gains, for each option you need to have a “yes” or “no” choice and put the gain in the “yes, I’m sure I want to wear this option”

This is because if you put it in the outfit option and only write one “yes” or “no” if the reader tries the other options, they will gain each outfit they wore, leading to mass confusion. You can support this thread though: FEATURE : Lose Gains

Example of a dressing game with gains:


Resetting your gains (also called flags) to test other options out: HOW TO: Reset Story Progress + Bonus Stuff :blob_sun:

2 Likes

Thank you so much! I’ll try this out! :relaxed::relaxed:

1 Like

Did you test it in the Portal? If the dressing game is in another chapter than the one you use the flags in, and you test in the Portal, it won’t work, only in the app. Your code looks okay to me.

It didn’t work even when I tried it on my phone, but I tried the dressing game with flags template and now it works! :grinning:

Ah, I’ve just realized what the problem was! :smiley: You didn’t include an additional Yes/No choice in every outfit option. You should have put the flag there to make it work.

Imma make another coffee. :,D

1 Like

Yes, haha! :stuck_out_tongue_closed_eyes:

1 Like

Closed: Marked as solved by op :yay: