Getting a Warning

I’ve been having trouble, I’m getting a warning saying “use @ CHAR walks to x y z in s”
but as far as I can see it’s all correct :thinking:


INT. UNIVERSITY HALL LEFT 1

@ GUS changes into GUS_navy-school-uniform
@ ELIZA changes into ELIZA_white-school-uniform
@ CLEO spot 0.546 -50 296 AND CLEO moves to layer -2 AND LEO spot 0.552 -37 309 AND LEO moves to layer -4 AND ELIZA spot 0.551 -83 295 AND ELIZA moves to layer -2 AND GUS spot 0.524 -146 314 AND GUS moves to layer -4
&CLEO walks to spot 0.546 175 308 in zone 1 in 3 AND LEO walks to spot 0.552 205 314 in zone 1 in 3
&zoom on 130 325 to 175% in 0
@ GUS walks to spot 0.524 128 311 in zone 1 in 5 AND GUS is walk_exhausted AND ELIZA walks to spot 0.551 105 296 in zone 1 in 3 THEN GUS is idle_exhausted

&zoom on 700 325 to 175% in 3
@pan to zone 2 in 3 AND GUS walks to spot 0.524 129 316 in zone 2 in 4 AND GUS is walk_exhausted AND ELIZA walks to spot 0.551 83 293 in zone 2 in 3 AND CLEO walks to spot 0.546 265 305 in zone 2 in 3 AND LEO walks to spot 0.552 300 311 in zone 2 in 3

@ ELIZA walks to spot 0.326 310 403 in zone 3 in 3 AND ELIZA moves to layer -4 AND GUS walks to spot 0.335 278 397 in zone 3 in 3 AND GUS moves to layer -5 AND LEO moves to layer -AND LEO moves to layer -2 AND CLEO moves to layer -4 AND CLEO moves to layer -2

@pan to zone 3 in 3 AND LEO walks to spot 0.552 164 312 in zone 3 in 3 AND LEO moves to layer -4 AND CLEO walks to spot 0.546 138 301 in zone 3 in 3 AND CLEO moves to layer -2

It means exactly like that, it need to be in that specific coding. You can’t specify the zones, it won’t work, so it has to be :

Do :
@ CLEO walks to spot 0.546 175 308 in 3

Do Not :
@ CLEO walks to spot 0.546 175 308 in zone 1 in 3

Idk why but that’s just how it’s formatted and also it needs to be like that for every one of them, Hope this helps.

You actually can specify the zone in the walk/spot commands (I do this all the time-- helps the characters stay/move to the zone you want them in, rather than be in another one by accident)

There’s nothing really jumping out at me as the real error. Can you please specify which line is giving you the error upon saving? It should say which command is the issue in the warning box.

2 Likes

Try putting all of your @CHARACTER moves to layer and @CHARACTER spot 0.100 000 000 on different lines.
I’ve tried to put them altogether once and got an error. Maybe it’s that?
Like @Lurhu mentioned you’d have to show us the specific line/error.

1 Like

it’s this line that’s giving the warning/error :thinking:
I’ve had no problem before :thinking: :woman_facepalming:


Sorry, lol. I didn’t know that, interesting, I guess I’ve been doing it the hard way, Iearned something new today.

1 Like

It could be that there’s a space between @ and ELIZA or that there’s a negative(-) next to the AND where it says “Leo moves to layer -AND” , sorry I’m just trying to help.

1 Like

OMG how did I not see that :woman_facepalming: Thanks @SASB

1 Like

No problem, happy to help.

1 Like

@Sydney_H solved - can you close this thread please?

1 Like

Solved and closed