Help my choices are not working

communication
general
community
coding

#1

Hi, I’ve been doing a dressing game with three outfits but the 3rd one just comes up with an error saying ‘Choices must follow dialog immediately, not a branch.’ and I’ve tried everything putting dialog in front of it, after it, in the middle of it and it just doesn’t seem to work.

Here is my current script.

} choice “Outfit 3” {
@YOU starts dustoff_loop
@YOU changes into Work3_defult

@YOU starts blow_kiss
NARRATOR
Do you want to wear this?

choice “Eww no” {
NARRATOR
Ok
@goto dressing_game

} “Gal I’m slayiggg” {

    NARRATOR
Great!

}
}

Thanks :blush:


#2

Moved to Directing Help & Tips as that’s where scripting questions live! :v:t2:


#3

Ah, thank you :blush: :sweat_smile:


#4

I think it’s because you have an @ in front of the goto. It suppose to be just goto dressing_game


#5

Thanks, I will try that out :blush:


#6

It’s still not working. :disappointed_relieved:


#7

Can you send a screen shot of your script?


#8

Sure.


#9

Here are choices 1 & 2


And here is choice three (the one that is not working)


#10

Oh it’s because you have the word choice in front of “Outfit 3”. Just get rid of that word.


#11

It’s not working because you write defult not default. And you don’t need choice in every choises, you need to do this:
choice “Option 1” {
} “Option 2” {
} “Option 3” {
}

I hope thats helps you


#12

Thank you :grinning:


#13

Thank you so much, I will try it :blush:


#14

Closing due to one month of inactivity :slight_smile:


#15