Help needed with advanced overlays!


#1

So I’m trying to use advanced overlays for the first time for a fantasy story I am working on, but for some reason the overlay itself won’t appear on my episode. This is the code I am using:

&overlay EARTH ORB create
&overlay EARTH ORB shifts to 180 250 in 0 in zone 1
&overlay EARTH ORB scales to 1.0 1.0 in 0
@overlay EARTH ORB opacity 1 in 0

Please tell me what I am doing wrong!


#2

Try switching places here maybe:
&overlay OVERLAYNAME shifts to 180 250 in zone 1 in 0


#3

Hey, thanks for replying so quickly, I just tried to see if it would work, but it still hasn’t made the overlay appear. I have no idea what to do.


#4

In the title of the background, you’ll need the overlay names.

for instance.
INT. LOCKERS - DAY with EARTH ORB to 1.0 180 250 in zone 1
If you don’t want it to appear until the middle of an episode, keep it’s opacity at 0, until you would like to use it…
Then make its opacity 1.
After all that, you can use the other commands as you wish


#5

So I’ve tried your idea and this is the code that I have, but for some reason the EARTH ORB still isn’t showing up:

INT. AUDITION STAGE - DAY with MAGIC RIFT to 1.0 0 100 in zone 2 with EARTH ORB to 1.0 180 250 in zone 1

I’ve tried it with other overlays and one other has worked, but the rest don’t seem to show up at all.


#6

It could be because Episode has declined your overlay? Check and see.


#7

Is it in the correct zone or in the correct spot? Can you see the white dotted lines that are around the overlay?


#8

That’s the thing all of them have been approved; there’s only one still pending, but I haven’t tried that one yet anyway.


#9

No, I can’t see any white dotted lines; should there be? I’m just literally so confused right now because I’m pretty sure my code is right and it works with one other overlay but all the others don’t show up at all.


#10

Zoom all the way out to see if your overlay is in the scene somewhere else.


#11

Thanks for the suggestion, but it still hasn’t worked; I’m starting to think my code just doesn’t like me…


#12

Can you post a screenshot of your script.


#13

Did you put the overlay’s name next to the background’s name at the beginning? Like

 BACKGROUND - NAME with OVERLAYNAME

I did that then went to to type

  @overlay OVERLAYNAME create

or

  &overlay OVERLAYNAME create

and it didn’t appear either. So I had to remove the one next to the background.
Hope this helps! :slight_smile:


#14


#15

No, I had one attached to the background name, but I used another later on and it still didn’t work. Then I put both on with the background name and it only worked for one of my overlays, not the one I actually needed though.


#16

Oh, okay then.
Maybe you should try

&overlay EARTH ORB create AND overlay shifts to 180 250 in 0 in zone 1 AND overlay EARTH ORB scales to 1.000 1.000 

Remove the “in 0” from @overlay EARTH ORB scales to 1.0 1.0 in 0
So it should look like @overlay EARTH ORB scales to 1.0 1.0


#17

It still didn’t work… :unamused:, but thank you for the suggestion anyway, I’m so glad that people are trying to help me even though my code is apparently holding a personal grudge.


#18

I’m so sorry it didn’t work! :sob: Last try? I have a feeling it’s something about the scales #?


#19

Have you tried testing it out in the app?


#20

You are amazing; it worked! I genuinely cannot thank you enough. I was stressing out so much about it, but thank you. I feel like such an idiot because it was something really small like the scales.