Help! Overlays not showing up?


#1

I’ll put an overlay into the previewer and it won’t show up. When I try Overlay Helper it says the overlay is there. I even went into the create section on the app to see if it was the previewer, but nope. Overlays don’t even show up there. It just has the outline of it. Help?


#2

Do you have the overlay in the right zone? Sometimes they can be way off the screen too, try zooming out a lot and see if you can spot it.


#3

I’ve tried that too. Even scaling up the overlay to see if I can see it.


#4

I even tried custom overlays and episode overlays. Neither of them show up.


#5

You have to add the opacity of the overlay in order to make it visible…

The command for that is-

@overlay OVERLAYNAME opacity 1 in 0

“1” represents the visibility of the overlay and “0” represents the time it should be visible…
You can change as you please


#6

It worked but that’s super weird. Usually I don’t need to do that and I thought opacity didn’t work in the previewer?


#7

You have to add the opacity to make it visible…
If you didn’t then you won’t be able to do this…and if you doing this on the web previewer check those overlay in the app previewer as well because web previewer is glichy and sometimes shows things that aren’t even there
So check it put in the app previewer…as well…:slightly_smiling_face::slightly_smiling_face:


#8

I just know that literally yesterday I was doing a whole bunch of coding with overlays and I never needed to use the opacity to have them show up. I did check the app previewer too before asking this question. It didn’t show up either, but now it does…


#9

How do you have it written into your script? Can you screenshot it? :thinking:


#10

Here is the way I have it now. I never had to add opacity before unless I wanted it to fade in.Capture


#11

At first I thought it had something to do with the @overlay OVERLAY create, but I did INT. BACKGROUND - NIGHT with OVERLAY and that did work either. It’s only working now because I did opacity, which I’m just confused on how it’s working now since I didn’t have to do that before. :woman_shrugging:


#12

Have you previewed your EVERY overlay in the app??


#13

When you put the overlay in the background title you don’t need opacity, it will automatically show up. When you use the create command to add in overlays you always need opacity or it won’t show up.


#14

if you’re asking if I tried a certain overlay, I don’t have that one. If you’re asking if I tested every single overlay in the catalog, I haven’t.

The AMBER overlay isn’t approved yet, so I thought that was a problem too. But I also tested it with an official overlay and it didn’t work either. Although it will probably now if I use the opacity command.

I’m just really confused on why I need to do that now.


#15

That’s just it :thinking: I did that before with a different overlay and it never showed up.


#16

No I meant that the overlays that you coded yesterday…
Are they showing up on the app??

That’s what I meant.


#17

But thank you! Both of you. I didn’t know that I had to do that with the create command.


#18

Ohhh, I’m not sure. Let me check. With those I added them to the background. This is the first time I’m trying the create command.


#20

Yes they show up.


#21

But thanks @S.Dsana and @Rune.episode! I get it now. Should I ask someone to close this?