Help with this code

Hi I have this scene where people walk away in a car park and one walks back but she won’t walk back. I’ve tried the @ Andy the & nothing is working it’s like it freezes :pensive: could someone please help me thank you so much

1 Like

Can I see the script?

1 Like

Copy here your code pls

1 Like

Can you take a picture of the script?

1 Like

@XTRA6 walks to spot 0.371 352 349 in zone 1 AND XTRA5 walks to spot 0.371 352 349 in zone 1
@XTRA5 exits right AND XTRA5 exits right

&XTRA2 walks to spot 0.485 208 346 in zone 1
&XTRA2 moves to layer 0

&SUMMER walks to spot 0.641 -34 222 in zone 1
&SUMMER moves to layer 3

@SUMMER walks to spot 0.641 195 246 in zone 1
@SUMMER moves to layer 3

    SUMMER
(I can't find Sasha anywhere all the cars are now gone)

@SUMMER walks to spot 0.452 161 368 in zone 1
@SUMMER moves to layer 3 AND SUMMER faces right

@speechbubble is 177 176 to 100% with tail_top_left
SUMMER (talk_armsraised_neutral)
Hey,

its the @XTRA 2 and summer that won’t walk back I have tried everything

&XTRA2 walks to spot 0.485 208 346 in zone 1
&XTRA2 moves to layer 0

&SUMMER walks to spot 0.641 -34 222 in zone 1
&SUMMER moves to layer 3

@SUMMER walks to spot 0.641 195 246 in zone 1
@SUMMER moves to layer 3

@SUMMER walks to spot 0.641 -34 222 in zone 1
@SUMMER moves to layer 3
@SUMMER walks to spot 0.641 195 246 in zone 1
@SUMMER moves to layer 3

Here’s why: in your original code SUMMER is coded to go to 2 different spots. So if your script uses the first spot it doesn’t make SUMMER walks back to the second spot, for some cases the script favors the last spot commands and the character won’t move at all.

Edit: if you use overlays it could get a bit buggy. I’ll edit a cleaner version for you here:

@SUMMER walks to spot 0.641 -34 222 in zone 1 at layer 3
@SUMMER walks to spot 0.641 195 246 in zone 1 at layer 3

From where they are walking - did you spot the characters on position from where they walk before you gived the walking command?

Also I reccomand to add time how long they have to make each walking.

If you write.
&SUMMER walks…
@SUMMER walks

It will ignore the first line since both is happeninng in the same time. If you want to walk first to first spot and then to second you need both to have @

1 Like

I did. also the XTRA 2 wont walk to the spot either but il try to do summers spot now

You need to first spot them on where they shoud be before they start to walk.:grinning:

tried that lol

@speechbubble is 129 395 to 100% with tail_bottom_right
SUMMER
Thats my time to go see ya.

@SUMMER walks to spot 0.641 460 208 in zone 1
@SUMMER moves to layer 3

@MATT walks to spot 0.758 -74 151 in zone 1 AND LUELLA walks to spot 0.578 -36 201 in zone 1
@MATT exits left AND LUELLA exits left

@XTRA9 walks to spot 0.398 439 371 in zone 1 AND XTRA8 walks to spot 0.362 -13 372 in zone 1
@XTRA9 exits right AND XTRA8 exits left

@XTRA6 walks to spot 0.371 352 349 in zone 1 AND XTRA5 walks to spot 0.371 352 349 in zone 1
@XTRA5 exits right AND XTRA5 exits right

@SUMMER spot 0.641 460 208 in zone 1
@SUMMER moves to layer 3

@SUMMER walks to spot 0.641 163 245 in zone 1
@SUMMER moves to layer 3 AND SUMMER is search_neutral

    SUMMER
(I can't find Sasha anywhere all the cars are now gone)

so i have summer walk off to fine her friend but she can’t fine her so she comes back

@speechbubble is 129 395 to 100% with tail_bottom_right
SUMMER
Thats my time to go see ya.

@SUMMER walks to spot 0.641 395 212 in zone 1
@SUMMER moves to layer 3

@MATT walks to spot 0.758 -74 151 in zone 1 AND LUELLA walks to spot 0.578 -36 201 in zone 1
@MATT exits left AND LUELLA exits left

@XTRA9 walks to spot 0.398 439 371 in zone 1 AND XTRA8 walks to spot 0.362 -13 372 in zone 1
@XTRA9 exits right AND XTRA8 exits left

@XTRA6 walks to spot 0.371 352 349 in zone 1 AND XTRA5 walks to spot 0.371 352 349 in zone 1
@XTRA5 exits right AND XTRA5 exits right

&SUMMER walks to spot 0.641 161 213 in zone 1
&SUMMER moves to layer 3 AND SUMMER is search_neutral

    SUMMER
(I can't find Sasha anywhere all the cars are now gone)

Thank you to all of you for your help it’s the background keep freezing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.