I need help with my tapable intro it is glitching

So I made a Tapable intro and the overlays are misplaced or they don’t even appear on the screen, I am not sure what i’ve done wrong.

This is the first part of the coding

Second part

This is how it looks, i am not sure where the Start overlay went

If you do know what’s the problem please tell me! This is my first story and i’m a beginner.

I would add:
@overlay STARTGOTH create
@overlay SKIPGOTH create
before the other overlay commands and if you do, you can remove the opacity 0 in 0 commands since the create commands both adds the overlays to the scene and makes them opacity 0 by default anyway.

Side note:
I’d also make the “opacity 1 in 1” commands have @ instead of & just so readers are forced to actually see the tappables appear first incase they try to tap without knowing what’s there.

I’d also change the contents of your branch because you have the overlay being opacity 0 and then opacity 1 and then if they tap it, it becomes opacity 0 again and then opacity 1 again when I think all you want it to do is direct them to the rest of the story. I would personally just have it become opacity 0 and insert a choice within it asking if they’re sure they’d like to start the chapter.
I’d also add a label so they can go back if they made a mistake.

label skip_start

@overlay STARTGOTH opacity 1 in 1 AND overlay SKIPGOTH opacity 1 in 1

tappable
“STARTGOTH” {

&overlay STARTGOTH opacity 0 in 0.5 AND overlay SKIPGOTH opacity 0 in 0.5

NARR
Are you sure you want to start this chapter?
choice
“Yes! I want to READ this chapter.” {

goto story_start

} “No, I made a mistake.” {

goto skip_start

}} “SKIPGOTH” {

&overlay STARTGOTH opacity 0 in 0.5 AND overlay SKIPGOTH opacity 0 in 0.5

NARR
Are you sure you want to skip this chapter?
choice
“Yes, I want to SKIP this chapter.” {

goto end_story

} “No, I made a mistake.” {

goto skip_start

}}

label story_start

#Story here.

label end_story

@pause for 0

You should also place the whole “Are you sure you’re finished reading this chapter?” at the end because with the way it is now, it will keep going even if they select the yes option.

1 Like

You have to create the overlays before adjusting them :relaxed: with:

@overlay OVERLAYNAME create

and then the rest of the coding you have of opacity, scale and shift
If the placing is what’s wrong try again doing:

@overlay OVERLAYNAME create
@overlay OVERLAYNAME opacity 1

and adjust them with the spot director and paste again the shift and scale :blush:

Should be good to go! :heart::+1:

1 Like

Oh and quick note just an extra advice! Instead of putting

@zoom on 0 0 to 100% in 0

you can put

@zoom reset

It’s much faster to code :relaxed:

1 Like

Thank you for telling me this! I will try and change it now and I’ll update you when i’m finished!! :heart:

1 Like

Of course!! I’m here if you need anything :relaxed::heart:

1 Like

Alright I’ll do that and post a picture of how it looks!

1 Like

So there’s an error that appeard well actually multiple lol

1 Like

I think the error comes from the scales and shifts after that, sometimes it marks the wrong line :sweat_smile:
Try erasing those and trying again :thinking:

Try erasing the spotting and adjusting them to the spot all over again, then copy and paste the coding between the lines of “create” and “opacity” :smiling_face_with_three_hearts:

Just edited my response in the hopes of helping you better than before :crossed_fingers:t2:

So I put the shift and scale coding but on the website it always shows different (the placing of the overlay, I am writing the story on mobile so I use the app to place things) This is the website:

Also, your “scales to” command for the STARTGOTH overlay needs to have a different numbers format than shifting so like 1.000 1.000 for example not 161 271.

&overlay STARTGOTH scales to 1.000 1.000 in zone 1 in 0

But your actual scaling numbers might be different in order to suit your screen/fit the zone.

So I will show you how I see the shift and scale


And skip


This is how the script looks now, it keeps saying there’s an error

why don’t you try spotting through the computer?? they may have different settings and it shows different :frowning:

I sadly don’t have a computer :pensive:

Try adding decimals to your scaling numbers instead of spaces like this:
0.586 0.586

ouh you’re coding everything through your phone?

1 Like

Yep