Issue with layers


#1

I am having an issue with my layers my character does seem to go behind the overlay.
I have a similar scene that’s with an aeroplane and the character goes behind the overlay and I don’t know what I am doing wrong.

EXT. AURORA HILLS - DAY with AURORA HILLS at layer 1
@cut to zone 2

@speechbubble is 158 281 to 100%

    NARRATOR
Text Here

    NARRATOR
Text Here

    NARRATOR

Text Here

@YOU moves to layer 0
@overlay AURORA HILLS to layer 1
@YOU enters from left to screen left
@YOU walks to spot 0.293 232 351 in 3 and YOU does it while walk_rear and YOU faces left
@YOU walks to spot 0.293 281 353 and YOU does it while walk_rear and YOU faces left

I have also tried it with this too

@overlay AURORA HILLS create
@overlay AURORA HILLS to layer 1
@overlay AURORA HILLS shifts to 0 0 in zone 2
@overlay AURORA HILLS scales to 1.000 1.000
@overlay AURORA HILLS opacity 1


#2

Avoid using layer 0 as I noticed that it’s glitchy, try -1


#3

i tried that too and it didn’t seem to work


#4

Sorry :slight_smile: I just noticed that you moved your character to the layer before she enters the scene

Try:

@YOU enters from left to screen left AND YOU moves to layer -1

You can also try:

@YOU stands offscreen left AND YOU moves to layer -1
@YOU enters from left to screen left

If this won’t work, place your character offscreen and move to a layer then walk to a scene using spot directing.


#5

No matter what I try it doesn’t seem to make any difference.


#6

Is your overlay in zone 2?


#7

The overlay doesn’t seem to be appearing…
I thought I would change the background to white and use it with the overlay and there is no overlay appearing.


#8

It’s not appearing at all?


#9

nope not at all


#10

so what’s your script now? do you have any errors?


#11

If u need any help go to Episode bomb
:joy::joy::joy::relieved:


#12

Nope just my background needs to be approved (the overlay is also pending)

INT. WHITE - DAY with AURORA HILLS 100 0 0 in zone 2 at layer 1

@cut to zone 2

@speechbubble is 158 281 to 100%

    NARRATOR
Text Here

    NARRATOR
Text Here

    NARRATOR

Text Here

@YOU stands offscreen left and YOU moves to layer -1
@YOU enters from left to screen left
@YOU walks to spot 0.293 232 351 in 3 and YOU does it while walk_rear and YOU faces left
@YOU walks to spot 0.293 281 353 and YOU does it while walk_rear and YOU faces left


#13

This post was flagged by the community and is temporarily hidden.


#14

Try this:

@YOU spot 1.280 -76 0 and YOU moves to layer -1
@YOU walks to spot 1.280 50 0


#15

Wait… do you want her to be in front of the overlay? :joy:


#16

I think the issue is the overlay not appearing.

Nah I wanted her to walk behind the overlay.


#17

One more thing I just noticed:

INT. WHITE - DAY with AURORA HILLS to 1.000 0 0 in zone 2 at layer 1


#18

So changed that and then the background appears with the white background and the character walks behind like it’s supposed to. As soon as i use the correct background with it, it stops working I will assume that it’s because the overlay and background isn’t approved yet.


#19

It should work even if it’s not approved it yet :thinking: weird…


#20

that’s what I thought too.

I went back to the start changed my background to a one zone background and the moved the move character to layer 0 to after the first walk and then for her to walk behind and it all works.

Thank you for your help

This can be closed @Jeremy @Sydney_H @Jesse