It say's there's a "{" without a matching...can't find it

It says there is a bracket without a matching but I can’t find it…

PENNY (think_rubchin)
(What now?)
choice “Wear one of the outfits mom picked out” {
@speechbubble is 151 254 to 100% with tail_top_right
PENNY (talk_condescending_atcamera)
Really?
@PENNY spot 1.280 38 23 AND zoom on 9000 0 to 101% in 0
@speechbubble is 171 339 to 100%
NARR
Tap on the dress you want to wear!
tappable
“DRESS1”{
@PENNY changes into PENNY_dress1
@PENNY walks to spot 1.280 253 24
PENNY (idle_exhausted_loop)
(Is this really what I’m wearing?)
choice “Yup” {
@speechbubble is 162 277 to 100% with tail_top_right
PENNY (talk_exhausted)
Whoopie.
@PENNY walks to spot 1.280 -99 37 AND PENNY is walk_exhausted_loop

}
“Naw” {
goto dress
}
}
“DRESS2”{
@PENNY changes into PENNY_dress2
@PENNY walks to spot 1.280 253 24
PENNY (idle_exhausted_loop)
(Is this really what I’m wearing?)
choice “Yup” {
@speechbubble is 162 277 to 100% with tail_top_right
PENNY (talk_exhausted)
Whoopie.
@PENNY walks to spot 1.280 -99 37 AND PENNY is walk_exhausted_loop

}
“Naw” {
goto dress
}
}
“DRESS3”{
@PENNY changes into PENNY_dress3
@PENNY walks to spot 1.280 253 24
PENNY (idle_exhausted_loop)
(Is this really what I’m wearing?)
choice “Yup” {
@speechbubble is 162 277 to 100% with tail_top_right
PENNY (talk_exhausted)
Whoopie.
@PENNY walks to spot 1.280 -99 37 AND PENNY is walk_exhausted_loop

}
“Naw” {
goto dress
}
}
}“Wear what you want” {
@cut to zone 2 AND zoom on 0 0 to 100% in 0
@PENNY walks to spot 0.955 85 191
@pause for 1
@PENNY is reach_kneel_neutral
@pause for 1
@zoom on 353 410 to 232% in 0
@PENNY is standup_neutral
@overlay PENNY OUTFIT FOLDED opacity 1 in 0
PENNY (talk_baby_worried_atbaby)
Clean enough.
@pause for 1
transition iris out in 1
}
}

I think this one hasn’t got a match!

I think it’s the very last } that’s the problem and also you have put 3 } in there :point_down:

Remove the very last bracket at the end (i bolded it above). And you forgot to add the @ sign to the transition command.

1 Like

The error is probably the computer complaining about the transition missing an @ that Dara pointed out, it likes to yell “There’s a { with no }!!!” when it encounters a confusing line within some brackets. But also that last } doesn’t have a mate, unless it isn’t shown in the scene you posted. :+1:

Ty! Its all good now :))

1 Like

thank you!

1 Like

Thanks sm!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.