Label and Goto are not working for me

communication

#1

Hi,

I am on chapter 13 on a story in INK and the label & goto branching always worked for me. I don’t know if it is a new bug, or just me.

I wanted my character to search for something and she stands in a hall with 4 doors. I want to give the reader the option to let the character look in every room.

This is my script:

label askinggame2

    CHARACTER (idle_rear)
Where should I take a look?

choice
“Door on the left”{

@CHARACTER walks to spot 0.709 88 254 in 1.5
INT. EVIDENCE ROOM - NIGHT
@CHARACTER stands screen left

    CHARACTER (idle_rear)
Hm, okay, it's not here.

@transition fade out black
INT. BRISTOLS DORM HALLWAY - DAY
@CHARACTER spot 0.709 88 254
@CHARACTER walks to spot 1.408 179 -60 in 1.5

goto askinggame2

}

My character just stands in her idle position forever and never returns to choose the other options.

And nearly the same script for the other 3 doors.
Is there something wrong or is it really just a bug?


#2

What exactly is the problem?
Do you get an error, or what happens?


#3

Oh, sorry.
My character just stands in her idle position forever and never returns to choose the other options.


#4

Does it work the first time? So do you get the choice the first time?


#5

Yes, I get the choice the first time, but after I let my character search one of the rooms, she can’t return to the choice where she can enter another room.
And the story doesn’t continue either. She just stands there. Even if I add text after the brackets of the whole choice.


#6

Have you tried changing goto in redo?


#7

Hm. I tried it now, but it turns out the same.


#8

are you using INK, classic, or Limelight?


#9

I’m using INK


#10

I tried using it in one of my stories (limelight and INK), it worked fine.
So, I don’t know what the problem is, the only thing I can think of is that there is a difference between your script and what is on the forum.


#11

i tried it aswell and it worked fine.


#12

And the whole thing worked for me just a few lines above (I wrote that a few weeks ago)

But even if I copy the same thing without changes, it won’t do a thing.


#13

Hm. Maybe it is a bug.

But thank you for your help :slight_smile:


#14

I don’t think it is a bug, can you sent me the whole thing in a PM?
From the moment the character enters the hallway and with all the doors?


#15

ahh, I guess I found my personal “bug”
The whole thing was within a big choice, and you can’t have labels in a choice.


#16

Hi.
The part you’ve put up here looks fine as far as I can tell., The problem might lay elsewhere.
Is it only this choice alt that gives you trouble or is it the whole choice?
Could you post the full choice script plz, might be easier to find what’s wrong then.

<3

PS. Ah, I see you’ve already found it.
Odd that it didn’t give you an error message for it…


#17

Thank y’all so much! I found the problem :slight_smile:
I put my label in another choice and that is not possible.


#18

No, a label always has to be available no matter what choice the reader picks. :upside_down_face:
Glad you found the problem. Happy coding.


#19

Glad this got resolved! Closing :v:t2:


#20