‘Label doesn’t exist’

coding

#1

Hey. I’m writing my first episode story and so far I haven’t had too big a problem until I tried to create a dressing game. It keeps coming up with the error ‘label doesn’t exist.’


I’ve looked on the forums and I’ve found nothing that helped. I’ve even tried another script and many different labels but the same thing happens.
I understand that there’s another error about not being able to have labels in choices but when I preview it in the episode app, the dressing game plays until it comes to the point where it should replay. I don’t know whether having it in the choice is effecting it but it is necessary to the story.
Please can someone help?

(This is my first time submitting something on the forums so I apologise if it’s in the wrong area).


#2

Labels cannot be inside brackets. You will need to put the dressing game outside of the choice and put a goto inside the choice that leads to the dressing game label.


#3

I tried this but is there a way to create the label (out of the choice brackets) that won’t appear elsewhere in the story?


#4

Put a label after the dressing game, then inside the choice that doesn’t have the dressing game put a goto that leads to the label after the dressing game, that way if they chose the other choice they don’t play through the dressing game part.


#5

I feel so silly asking but where do you actually put the dressing game?


#6

Because I can’t put it in the choice brackets but I can’t put it anywhere else because then it’ll appear elsewhere…?


#7

CHARACTER
Dialogue.

choice
“Option” {

goto clothing1

} “No” {

goto after_clothing

}

label clothing1

[dressing game here]

label after_clothing

[continue story here]


#8