Layer not adjusting?

Hi everyone! I am trying to have my characters move layers and for some reason they just stay in the same layer. All my other lines with this command works, but these guys keep staying in layer 2 and it’s driving me crazy. Here is the code I have:

@GUARD walks to screen right in zone 3
@GUARD moves to layer 4
@GUARD faces left
@GUARD 2 walks to screen left in zone 3
@GUARD 2 moves to layer 4
@GUARD 2 faces right

(The characters are named “GUARD” and “GUARD 2”

I initially had the move layer command above the walk commands and it caused the same issue. In the preview it specifically shows them in layer 2 after they move in this scene.

Thank you!!

@GUARD walks to screen right in zone 3 AND GUARD faces left AND GUARD moves to layer 4
@GUARD 2 walks to screen left in zone 3 AND GUARD 2 faces right AND GUARD 2 mives to layer 4

It didn’t work

Try this!

@GUARD walks to screen right in zone 3 and GUARD moves to layer 4 and GUARD faces left and GUARD 2 walks to screen left in zone 3 and GUARD 2 moves to layer 4 and GUARD 2 faces right

Thanks!! How exactly do I do that? I didn’t know I could edit the episodes in the app

Didn’t work either :frowning: :slightly_frowning_face:

You could probably do this in the web previewer, but I only use the app for previewing because it tends to be the most accurate out of the two.

  1. Okay, so you navigate to the Create tab.

  2. Then you can sign in using whatever method you used to sign into your portal.

  3. Then your stories should appear in the My Stories section and you can play whichever story you’re currently working on.

  4. Once you’re at the section of your story where you want to adjust the overlays (or characters), you can press the Show Helpers button.

  5. You then press the Spot Directing button and all of your layering options will be displayed on the left side.

You can select different characters/overlays by pressing the Change Char and/or Change Overlays buttons. :blush:

Does it automatically save after you do that?

The only place that has the Save option is the portal, but it helped me match the layering the app to what I already coded in the portal (and saved there). So technically no, there isn’t a Save button in either previewer but I hope it solves your problem, like it solved mine awhile back. (:

Oh no it doesn’t work then. It’s like the story just ignores what layer I’m trying to put the 2 guards on and won’t move them from layer 2 for whatever reason. I just have a couple other characters and layovers in the scene too so it puts them under other things they should be over

If you’ve tried the app and it didn’t work for you, then maybe delete the scene, save and try coding it again or create duplicate characters of your guards and try the scene again with them instead. :thinking:

Thanks for the advise! I rewrote the scene using spots rather than the simple commands and it fixed it :slight_smile:

1 Like

No problem! I’m glad your issue’s been fixed. :grinning_face_with_smiling_eyes:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.