Moving overlays problem

Hi! I’ve been posting a lot, but for good reason I swear, I just have a lot of questions because I’m speeding through coding & script writing :sob:. Okay! So,

I’m working with overlays right now, and I’ve come across one particular problem. I’m using an overlay made by Episode, and it’s a car overlay. I’m also using a looping background.

My overlay keeps moving to the side of my screen whenever i preview my script?? And I’m not trying to animate it. I’m just trying to have it THERE. ON THE SCREEN. So that the car overlay is there and the looping background is in the windows, and so I can have a couple characters in the car seats. I’m confused as to why it’s doing this because I don’t think I have any commands that would animate it, and I’m not purposely trying to animate it. I just want it to be still. As if it was a part of the background!! Someone help :sob::sob:

Here is that part of my script:

EXT. METROPOLIS CITY STREET LOOPING - DAY with INT. LUXURY SUV - BACK - DAY to 1.078 -42 in zone 1 at layer 1

@ADELINE spot 1.946 154 -153 in zone 1 at layer 1 AND ADELINE faces right
@ADELINE starts idle_sit_serious_loop

NARR (ADELINE)

|bold| 8:00 AM.

try including the overlay outside of the title- there was an update in dec 2023 with looping bg and using overlays with it I think that’s why

1 Like

Looping Backgrounds via Donacode :curly_loop:

  • You can now have any background loop on screen via Donacode! All you do is specify a loop speed as the last part of your background (after any overlays). Examples:
    • Without overlay
      • EXT. ABBEY GARDEN - DAY with loop speed 320
    • With un-moving overlay
      • EXT. ABBEY GARDEN - DAY with BANISTER SIMPLE with loop speed 320
    • With negative loop speed and un-moving overlay
      • EXT. ABBEY GARDEN - DAY with BANISTER SIMPLE with loop speed -1000
    • With an overlay that moves along with the background
      • EXT. ABBEY GARDEN - DAY with loop speed 320
        &overlay DUST CLOUD WHITE create
        &overlay DUST CLOUD WHITE shifts to 480 240
        &overlay DUST CLOUD WHITE scales to 1.0 1.0
        &overlay DUST CLOUD WHITE rotates 0 anchor point 0.5 0.5
        &overlay DUST CLOUD WHITE to layer 1
        &overlay DUST CLOUD WHITE opacity 1
        &overlay DUST CLOUD WHITE shifts to 480 240 in 0 THEN overlay DUST CLOUD WHITE shifts to -160 240 in 2 loop INFINITE times
      • Explanation: We have the background moving at 320 units per second; the overlay is moving a distance of 640 units in two seconds to match.
  • This works with your custom backgrounds as well!

Try this new method instead!

1 Like

Since you don’t want the looping effect on this one just don’t use this line, put it in like you normally would- if you want you can give me the shift and scale I can code it for you

1 Like

tysm for this!! (So sorry for late reply, I haven’t been active)

Unfortunately, I just tried the un moving overlay code, and the overlay still moves. ATP im just not sure what’s going on.

Could you repost your code? I’m going to have a look at it.

Sorry but where is the third number? :sweat_smile:

There are three numbers for an overlay. The scale, as well as X Y value

So something like this:

EXT. METROPOLIS CITY STREET LOOPING - DAY with INT. LUXURY SUV - BACK - DAY to 1.078 -42 0 in zone 1 at layer 1

You can also use the create command when it comes to an overlay! Example:

EXT. METROPOLIS CITY STREET LOOPING - DAY

&overlay INT. LUXURY SUV - BACK - DAY create
&overlay INT. LUXURY SUV - BACK - DAY scales to 1.078 1.078 in zone 1 in 0
&overlay INT. LUXURY SUV - BACK - DAY shifts to -42 0 in zone 1 in 0
&overlay INT. LUXURY SUV - BACK - DAY to layer 1
&overlay INT. LUXURY SUV - BACK - DAY opacity 1 in 0

&ADELINE spot 1.946 154 -153 in zone 1 at layer 1 AND ADELINE faces right AND ADELINE is idle_sit_serious_loop

NARR (ADELINE)
|bold| 8:00 AM.

I have no idea what your shifts to command numbers are as only -42 was given, so I just put 0 as a placeholder.