Music's not working? [HELP ME OUT PLEASE :(]


#1

Hello there, I am new to the writer’s portal and I have tried to denacode exactly as written in the guideline but I can’t seem to make the music plays for me :confused:

My script was like this:
music music_whimsicalpiano

And I get this instead on the upper part of the preview box:
Error: playWebAudio failed: TypeError: this.createConstantSource is not a function. (In ‘this.createConstantSource()’, ‘this.createConstantSource’ is undefined)

Can someone help me solve this? I’ve spent hours trying to get this fixed :frowning:

Thanks a lot!


#2

Can you send me a screenshot of the script? Press alt+print screen (prt sc or sysrq) and then paste it pressing ctrl+v


#3

Or try typing music whimsicalpiano


#4

It’s like this, but I’ll try your suggestion now


#5

Nope, not working at all :frowning:


#6

have you ckecked you laptop’s/Pc’s volume?


#7

I have, and it’s on high. I tried to played the music before I wrote it in the script and it worked fine. But somehow I couldn’t play it after I put it in the script :confused:


#8

I’m not sure though, but can you try resetting
volume music 80 0
Bc sometimes appear problems from this


#9

@maradee pls tell me if it didn’t work out


#10

for now I’ve tried to remove it and it still says the same thing, still the error message :confused:

sorry to bother you tho :frowning:


#11

Ugh, I really don’t know how to help you from now on , and not bothering me


#12

and you still can’t hear the music, even with the error message?


#13

haha :cry: that’s okay, I’ll try to meddle this myself later :")


#14

Not when I’ve put it in the script… but other than that, the music plays fine


#15

Did I code wrongly?


#16

I checked my script, and your coding is exactly with the your coding (the music part) except that it doesn’t show me any error messages. I can send you a screenshot if you want of my coding.


#17

btw, when you save your story, does is show any error problems?


#18

omg really?? that’ll be very helpful for me if you show me your coding😂

and yes, it showed up after I saved my progress :confused:


#19

it’s just a hunch but will restarting the script (moving the existing to a new one) help me solve this?


#20

Sorry, for the late responding, sending it to you now