My character keeps going on top of the overlay

image
image

I’m trying to make the character go behind the desk and when she walks into the scene, it works but when she actually gets to screen center, she goes on top of the overlay. Why is that?

Put her in negative layer

Instead of just layer 1 try’s layer -1 2 or what-ever you likes

@YOU spot … in zone 1 at layer 0, -1, -2…basically any number lower than 1

Remove what you current have, and paste this into your script, instead… and you’ll have no problems! :point_down:t3:


INT. TRENDY INDUSTRIAL FLAT LIVING ROOM - NIGHT
&overlay POLICE STATION DESK COMPUTER create
&overlay POLICE STATION DESK COMPUTER shifts to -73 -54 in zone 1 in 0
&overlay POLICE STATION DESK COMPUTER scales to 0.888 0.888
&overlay POLICE STATION DESK COMPUTER opacity 1 in 0
&overlay POLICE STATION DESK COMPUTER to layer 1

@YOU spot 1.280 305 -9 in zone 1 at layer 0

@cut to zone 1
@zoom on 160 284 to 109% in 0

&YOU walks to spot 1.280 133 -9 in zone 1 in 1.5 AND YOU does it while walk_neutral THEN YOU is transition_stand_to_sit

@pause for 3.5


:point_up_2:t3: Obviously pause for however long you want. I just added enough of a pause to cover her walking, the transition time from standing to sitting… and then a quick 1 second glimpse of her sitting… prior to doing any other animation.

But if you’d like her to [for example] type as soon as she sits down, then you’d pause it for 2.5 and then add the type_sit_neutral_loop afterwards!

But because she’ll move slightly out of position with the typing animation, you’ll need to spot direct her [again] after the 2.5 pause.

So it’d be: :point_down:t3:

INT. TRENDY INDUSTRIAL FLAT LIVING ROOM - NIGHT
&overlay POLICE STATION DESK COMPUTER create
&overlay POLICE STATION DESK COMPUTER shifts to -73 -54 in zone 1 in 0
&overlay POLICE STATION DESK COMPUTER scales to 0.888 0.888
&overlay POLICE STATION DESK COMPUTER opacity 1 in 0
&overlay POLICE STATION DESK COMPUTER to layer 1

@YOU spot 1.280 305 -9 in zone 1 at layer 0

@cut to zone 1
@zoom on 160 284 to 109% in 0

&YOU walks to spot 1.280 133 -9 in zone 1 in 1.5 AND YOU does it while walk_neutral THEN YOU is transition_stand_to_sit

@pause for 2.5

@YOU spot 1.280 168 18 in zone 1 at layer 0
&YOU faces left AND YOU is type_sit_neutral_loop

1 Like

Thank you so much!! It worked :smile:

1 Like

Aww, you’re welcome! I’m glad I could help. :blush:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.