My name template is not working!

Hi guys!

So I was putting this template in my script:

    NARRATOR
So... what's your name?

label first_name_input

input What’s Your First Name?|What’s Your First Name?|Done(FIRSTNAME)

if (FIRSTNAME is “”) {

    NARRATOR
You do need a name...

goto first_name_input

} else {
continue
}

But when I try to preview it, it just skips right to next dialogue. It shows the So… Whats your name? But then it skips the entire thing. Any idea on how i can make it work? Thank you!

1 Like

Hi well I can help you :wink: tell me did you let customize your MC? Or you just wanted to give readers their name and you don’t want them to customize them?

Actually, I have it before customization template, but that template is from someone else. I hope its okay.

1 Like

Yes it’s okay then now , if you want them to see their name on the MC you created is simple , you need to go on you story , Characters , to your MC Chara and write on the display name of your MC FIRSTNAME save it and try it on the app , in the script must be your MC characters name also if you some characters to call them with the name you chose you must insert [FIRSTNAME] and it will appeared the name they choose

i know that its just that in web previewer the script for the name isnt working :confused:

That’s supposed to be like that. Test it on your app and it’ll probably work. Also, try putting:

NARRATOR
Hi, [FIRSTNAME]!

Into your script. It should say, Hi, autobot! If it says that, it means it’s working.

It’s okay it’s really like that in the web prieview ot doesn’t appear only in the app , it appears

Oh thank you so much @haruka @Jacquelyne :heart:

2 Likes

You’re welcome

Oh no, I just tried to type that in the script but it isnt working! What do I do?

What exactly did you type? Could you send a screenshot of it and the error message?

MARY (talk_reassure_neutral)
Guys, this is [FIRSTNAME].

Whenever there is the [FIRSTNAME] on Web Previewer it just says: FIRSTNAME without the brackets instead of autobot as you told. I dont know what to do honestly. It isnt an error message though, it just doesnt display.

Are you absolutely sure you didn’t put the full stop between the brackets?

What do you mean?

As in, did you think you might’ve done:
MARY (talk_reassure_neutral)
Guys, this is [FIRSTNAME.]
So, I mean, do you think you might’ve put the . in the square brackets?

Oh I didnt do that. The dot is outside the brackets.

Should it be in the brackets?

No.

That is very strange. Try saving it and reloading it, and then if it still doesn’t work, it may be a bug.

Alright, will do! :heart: