My overlay isn't moving, but its code is changing

I placed my overlay in the script, when I was about to spot direct it, the previewer wouldn’t let me, the selection part was moving, but the overlay itself wasn’t, does anyone else have this issue and how do I resolve it?

If you have just created your overlay in the script then you have to put the shift numbers twice in the same row so @overlay shifts to 95 225 95 225

1 Like

Thank you, I’ll try that right now!

You need to set the opacity after you have placed it in your script
@overlay TV_PNG opacity 1 in 0

Moved to Directing Helps and Tips since this is about coding.
Make sure to check out our Forum Tutorial for more info about where to correctly create topics, and feel to PM me if there are any questions. :wink:

1 Like

It didn’t work, I’m still confused.

It does work, but there’s a duplicate that I can’t remove.

try to put the overlay when you placed the background what I mean by that is the shifts goes last and scale goes first


INT. BLACK - NIGHT with TV to 95 225 0.001

Okay, I’ll try that too,

I tried it, the overlay doesn’t appear in the preview screen.

Have you already added it to the background?

INT.background with OVERLAY NAME to (scale) (shift.) ?

Or are you doing the create?

INT background

@OVERLAY create
@OVERLAY shifts to (shift numbers twice) in zone (zone number.)
@OVERLAY scales to
@OVERLAY opacity 1 in 0

I’m doing create.

For create try the format I’ve done above rember that the shift numbers needs to be added twice right after eachother

I know, I’ve tried that, and it isn’t appearing still.

Hmm :thinking: could you copy and paste the code you have tried please…

Wait I’ve just realised it’s the scale you have to put twice not the shift :joy:

@overlay OVERLAYNAME create
@overlay OVERLAYNAME scales to (insert scale twice.(
@Overlay OVERLAYNAME shifts to (insert shift number.) in zone (zone number)
@overlay OVERLAYNAME opacity 1 in 0

1 Like

Oh, I tried this one, it works now, thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.