Overlay infinite loops don't work


#1

I used to use the overlays looping commend, and now I can’t use the infinite loop commend, only the specific number of times…

I write it like:

-some commend- loop INFINITE times

And it doesn’t work!

No matter with what overlay, uploaded one, Episode one, approved, not approved, in the web preview, in the mobile preview, and it just does nothing!

Does anyone know how to solve this? It is so frustrating because it used to work, and now it doesn’t work!


#2

Can I see an example of your commands?


#3

Sure, just a moment, I’ll get a screenshot.


#4

This is an example I just made, it’s not from a story, but the code is completely valid, and it doesn’t give an error, yet, it doesn’t work.

This is the code:

And when I test it, it does the commend one time instead of looping it.

Does anybody who might see this has a solution??


#5

Idk if it’s a default but you might want to use &

Cuz if not it’ll loop forever


#6

The loop doesn’t work for rotating overlays. Someone else had this same problem. What you have to do is rotate the overlay, clear it, then replace the overlay, then rotate again and put that on loop


#7

Sounds good to me


#8

I do use the &, I just didn’t use it in the example, because there’s no dialogue and it doesn’t really matter, it was (supposedly) supposed to go forever.


#9

cool


#10

I’m not sure how that works, if I’ll just replace it with a different one, won’t it just do the same thing with the loop as long as I use it on rotating?


#11

I don’t mean replace as in put in a different overlay. I mean to re-add that overlay.


#12

I can try that, but sometimes there are problems with the create commend, it doesn’t work for me half the time and I just add all of the overlays for scenes at the beginning and make them be at 0 opacity or make a new scene :slightly_frowning_face:


#13

When you use the create command, you have to add the shifts, scales, and opacity commands as well


#14

I know that, and I do that, but in some of the time there are problems with it.


#15

I tried that technique with clearing it and then creating and rotating again and then using the loop, and it gives me an error that says: “Loop command can only be used with Overlay Animaton commands”

What should I do with it??


#16

What did you type in? The code/example I provided in the link above works; the whole thing is just overlay animation commands. So just copy and paste that whole thing and replace the overlay name, shift coordinates, and scale size with your own and test it out.


#17

I tried to, it’s still says the same thing.


#18

Can you copy and paste what you have?


#19

@overlay ANGEL EMOJI 1 rotates 360 anchor point 0.5 0.5 in 0.2 THEN overlay ANGEL EMOJI 1 clear THEN overlay ANGEL EMOJI 1 create THEN overlay ANGEL EMOJI 1 shifts to 161 268 and overlay ANGEL EMOJI 1 scales to 1.264 1.264 and overlay ANGEL EMOJI 1 opacity 1 in 0 THEN overlay ANGEL EMOJI 1 rotates 360 anchor point 0.5 0.5 in 0.2 loop INFINITE times

This is what I have, I just changed a few things to match to my case. (And again, this was not from a story, just to test it, it’s an example story to test things from time to time)


#20

I’m not sure why that error is coming up, but if you just replace all the and’s with then’s, it will work.