Overlay keep saying -nan -nan

So I’m trying to do that overlay animation trick that looked so cool, so I tried to do a test run but nothing is happening! When I try to edit it the helper isn’t showing my overlay… And I keep getting “overlay scales to -nan -nan”.
I tried to edit it but nothing seems to be working… can someone please help me?

What background are you using, if I may ask?

The Italian restaurant

Can you post a screen shot of your script maybe? :slight_smile:

INT. ITALIAN RESTAURANT OL - NIGHT
#1
&overlay OPEN1 create
&overlay OPEN1 shifts to -6 1 in zone 1
&overlay OPEN1 scales to 1.716 1.716
&overlay OPEN1 opacity 1 in 0

&overlay OPEN2 create
&overlay OPEN2 shifts to -6 1 in zone 1
&overlay OPEN2 scales to 1.716 1.716
&overlay OPEN2 opacity 1 in 0.3

&overlay OPEN3 create
&overlay OPEN3 shifts to -6 1 in zone 1
&overlay OPEN3 scales to 1.716 1.716
&overlay OPEN3 opacity 1 in 0.3

&overlay OPEN4 create
&overlay OPEN4 shifts to -6 1 in zone 1
&overlay OPEN4 scales to 1.716 1.716
&overlay OPEN4 opacity 1 in 0

&overlay OPEN5 create
&overlay OPEN5 shifts to -6 1 in zone 1
&overlay OPEN5 scales to 1.716 1.716
&overlay OPEN5 opacity 1 in 0.3

&overlay OPEN6 create
&overlay OPEN6 shifts to -6 1 in zone 1
&overlay OPEN6 scales to 1.716 1.716
&overlay OPEN6 opacity 1 in 0.3

&overlay OPEN7 create
&overlay OPEN7 shifts to -6 1 in zone 1
&overlay OPEN7 scales to 1.716 1.716
&overlay OPEN7 opacity 1 in 0

&overlay OPEN8 create
&overlay OPEN8 shifts to -6 1 in zone 1
&overlay OPEN8 scales to 1.716 1.716
&overlay OPEN8 opacity 1 in 0.3

&overlay OPEN9 create
&overlay OPEN9 shifts to -6 1 in zone 1
&overlay OPEN9 scales to 1.716 1.716
&overlay OPEN9 opacity 1 in 0.3

I don’t see any issues with your coding :thinking: Are you getting an error?

I’m not getting an error, I can’t move the overlay. Like when I try to drag the overlay the helper readout doesn’t show any movement and when I try to retype the coding I keep getting “overlay scales to -nan -nan” in the helper readout

Can you see any of your overlay on-screen at all? :thinking:Sometimes overlays are so large that it looks like they’re not shifting.

I can’t see it at all

I suppose you could try adding your overlay to a smaller canvas in a editing app so the overall pixel size and dimensions will be smaller and then save it, upload it to the portal and try again. I’m just assuming the overlay could be that large that you don’t see it and each shift or scale you do could be doing very little to change the overlay. Worth a try though I think!

Turns out the coding had a problem, but it’s fixed now. Thank you for trying to help me :blossom: :blossom:

1 Like

Oh, that’s good! And you’re welcome. :blush:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.