Overlay Layering Issue?!

:sleepy: :sleepy: :sleepy: :sleepy: :sleepy:
I’m needing some help! :shushing_face: :mask:

Basically I’m adding in my intro for my new story but I’ve got the title made from overlays that need to be on top of the other overlays underneath. I’ve tried moving the overlays in the correct layers when I preview the overlays I want on top of everything else it’s saying they’re on a different layer to the layer I’ve set them too. :frowning_face:
Can anyone please help me out?

EXT. GREEN - DAY
&cut to zone 2
&zoom on 455 473 to 215% in 0
&overlay OPENINGPT_00 to layer 0 AND overlay OPENINGPT_01 to layer 1 AND overlay OPENINGPT_02 to layer 2 AND overlay OPENINGPT_03 to layer 3 AND overlay OPENINGPT_04 to layer 4 AND overlay OPENINGPT_05 to layer 5 AND overlay OPENINGPT_06 to layer 6 AND overlay OPENINGPT_07 to layer 7 AND overlay OPENINGPT_08 to layer 8 AND overlay OPENINGPT_09 to layer 9 AND overlay OPENINGPT_10 to layer 10 AND overlay OPENINGPT_011 to layer 11
&overlay PTSD_TITLE_P to layer 13 AND overlay PTSD_TITLE_T to layer 13 AND overlay PTSD_TITLE_S to layer 13 AND overlay PTSD_TITLE_D to layer 13 AND overlay PTSD_SHANE to layer 12
@overlay PTSD_TITLE_P create
@overlay PTSD_TITLE_P shifts to 28 358 in zone 2 in 0
@overlay PTSD_TITLE_P scales to 0.371 0.371
@overlay PTSD_TITLE_P opacity 1 in 0
@overlay PTSD_TITLE_T create
@overlay PTSD_TITLE_T shifts to 66 360 in zone 2 in 0
@overlay PTSD_TITLE_T scales to 0.361 0.361
@overlay PTSD_TITLE_T opacity 1 in 0
@overlay PTSD_TITLE_S create
@overlay PTSD_TITLE_S shifts to -28 246 in zone 2 in 0
@overlay PTSD_TITLE_S scales to 1.540 1.540
@overlay PTSD_TITLE_S opacity 1 in 0
@overlay PTSD_TITLE_D create
@overlay PTSD_TITLE_D shifts to 130 364 in zone 2 in 0
@overlay PTSD_TITLE_D scales to 0.346 0.346
@overlay PTSD_TITLE_D opacity 1 in 0
@overlay PTSD_SHANE create
@overlay PTSD_SHANE shifts to 66 360 in zone 2 in 0
@overlay PTSD_SHANE scales to 0.361 0.361
@overlay PTSD_SHANE opacity 1 in 0
volume music 50 2000
music music_meanpop

@overlay OPENINGPT_00 create
@overlay OPENINGPT_00 shifts to -28 246 in zone 2
@overlay OPENINGPT_00 scales to 1.540 1.540
@overlay OPENINGPT_00 opacity 1 in 0
&set hsl 0 0 0 in 0.5
@transition fade in green 1.5
@overlay OPENINGPT_01 create
@overlay OPENINGPT_01 shifts to -28 246 in zone 2
@overlay OPENINGPT_01 scales to 1.540 1.540
@overlay OPENINGPT_01 opacity 1 in 1
@overlay OPENINGPT_02 create
@overlay OPENINGPT_02 shifts to -28 246 in zone 2
@overlay OPENINGPT_02 scales to 1.540 1.540
@overlay OPENINGPT_02 opacity 1 in 1
@overlay OPENINGPT_03 create
@overlay OPENINGPT_03 shifts to -28 246 in zone 2
@overlay OPENINGPT_03 scales to 1.540 1.540
@overlay OPENINGPT_03 opacity 1 in 1
@overlay OPENINGPT_04 create
@overlay OPENINGPT_04 shifts to -28 246 in zone 2
@overlay OPENINGPT_04 scales to 1.540 1.540
@overlay OPENINGPT_04 opacity 1 in 1
@overlay OPENINGPT_05 create
@overlay OPENINGPT_05 shifts to -28 246 in zone 2
@overlay OPENINGPT_05 scales to 1.540 1.540
@overlay OPENINGPT_05 opacity 1 in 1
@overlay OPENINGPT_06 create
@overlay OPENINGPT_06 shifts to -28 246 in zone 2
@overlay OPENINGPT_06 scales to 1.540 1.540
@overlay OPENINGPT_06 opacity 1 in 1
@overlay OPENINGPT_07 create
@overlay OPENINGPT_07 shifts to -28 246 in zone 2
@overlay OPENINGPT_07 scales to 1.540 1.540
@overlay OPENINGPT_07 opacity 1 in 1
@overlay OPENINGPT_08 create
@overlay OPENINGPT_08 shifts to -28 246 in zone 2
@overlay OPENINGPT_08 scales to 1.540 1.540
@overlay OPENINGPT_08 opacity 1 in 1
@overlay OPENINGPT_09 create
@overlay OPENINGPT_09 shifts to -28 246 in zone 2
@overlay OPENINGPT_09 scales to 1.540 1.540
@overlay OPENINGPT_09 opacity 1 in 1
@overlay OPENINGPT_10 create
@overlay OPENINGPT_10 shifts to -28 246 in zone 2
@overlay OPENINGPT_10 scales to 1.540 1.540
@overlay OPENINGPT_10 opacity 1 in 1
@overlay OPENINGPT_11 create
@overlay OPENINGPT_11 shifts to -28 246 in zone 2
@overlay OPENINGPT_11 scales to 1.540 1.540
@overlay OPENINGPT_11 opacity 1 in 1
@pause for 2

1 Like

i think you have to create the overlays in your script before changing the layers, otherwise it doesn’t do anything. hope this helps :relaxed:

1 Like

You should put this part:

After everything.

1 Like


Here’s the issue these opening overlays are at a layer that I didn’t set them too. :sleepy: :sleepy: :mask: :mask:

overlay OPENINGPT_05 moves to layer 5

Same goes applies to the rest of the overlays.

I’ve tried that and it still says it’s in layer 19

You can try to put it in the format to create the overlay first instead of putting the layer before creating the overlay.

&overlay OPENINGPT_00 create
&overlay OPENINGPT_00 opacity 1 in 0
&overlay OPENINGPT_00 shifts to X Y in zone #
&overlay OPENINGPT_00 scales to S S
&overlay OPENINGPT_00 moves to layer #

you can put them on your background, then all you have to do is say &overlay NAME opacity whatever, it sometimes helps with errors and makes it easy to comb through layering issues


so all of this can go into the background like this
with OPENINGPT_00 to 1.000 0 0 in zone at layer 0 with etc. etc. (it saves you lines)

if you don’t want the OPENINGPT overlays to appear instantly just use the same thing you did here. AND overlay OPENINGPT_00 opacity 0 in 0. (again saves lines. now with the portal being buggy and all is best not to have to many lines.)

Question: Do you want the overlays to appear as animated? If yes you don’t have to use layers.

you can do it with opacity.

@overlay OPENINGPT_00 opacity 1 in T (seconds. usually 0.1)
@overlay OPENINGPT_01 opacity 1 T

if you want the overlay before to disappear again animated.

@overlay OPENINGPT_00 opacity 1 in T
&overlay OPENINGPT_00 opacity 0 in T
@overlay OPENINGPT_01 opacity 1 in T

if you use this you can just have all the overlays in the same layer.

i used the first coding to get this

1 Like

Yeah the background is animated I wanted to make it so the title would appear and disappear until the end. So I guess I’d need to put most of this in the Background and not have layers in it?

yep

Well I’ve probably done it wrong but nothing is animating. Plus the overlays that need to be above are still not showing through.

hhmm can you pm me the script? i’ll probably answer you in 2-3 hours.

as you ware told above first you have to create the overlays and only after you create them set the layers for them.

You set layers for overlays which are not yet created therefore after you create them they are not at the layers.

also if you are trying to make like gif animation with your intro here is how its done

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.