Overlay won't appear in scene on app

Hi, I need help. So I used this overlay twice (once to break the alarm clock and the second time to reverse from it happening) and when I tried to use it the second time it won’t appear and my other overlays work though. Help?

Here’s the parts where I add it:

 LEANNE (talk_armsraised_neutral)
Une matis! Une matis!

@overlay GREEN MAGIC create
@overlay GREEN MAGIC shifts to 42 202 in zone 2
@overlay GREEN MAGIC scales to .087 .087
@overlay GREEN MAGIC opacity 1
@overlay GREEN MAGIC shifts to 115 215 in 2 in zone 3
sound candybowl_crash
music off
@overlay GREEN MAGIC clear
&overlay GLASS HOLE create
&overlay GLASS HOLE shifts to 128 222 in zone 3
&overlay GLASS HOLE scales to .131 .131
&overlay GLASS HOLE opacity 1
&overlay GLASS HOLE moves to layer 1
&overlay GLASS PIECES create
&overlay GLASS PIECES shifts to 27 14 in zone 3
&overlay GLASS PIECES scales to 1.000 1.000
&overlay GLASS PIECES opacity 1

(This is where the green magic overlay doesn’t appear)
LEANNE (talk_armsraised_neutral)
Reverseus!
@pan to zone 3
@zoom on 764 160 to 269% in 2
@overlay REVERSE create
@overlay REVERSE shifts to 156 278 in zone 3
@overlay REVERSE scales to .089 .089
@overlay REVERSE opacity 0
@overlay REVERSE opacity 1 in 2
sound radio_tuning
@overlay REVERSE opacity 0 in 1 then overlay REVERSE opacity 1 in 1 loop INFINITE times
@overlay GREEN MAGIC create
@overlay GREEN MAGIC shifts to 115 215
@overlay GREEN MAGIC scales to .087 .087
@overlay GREEN MAGIC opacity 1
@overlay GREEN MAGIC scales to 42 202
@overlay GLASS HOLE clear
@overlay GLASS PIECES clear

I believe you did not specify a zone for the green magic overlay and it defaulted to the bottom left of zone 1. Since you’ve panned to zone 3, it’s not visible from where you are.

I’ve tried that beforehand and it still didn’t work and I was messing around with it.

That’s the only thing I’ve noticed as well :sweat_smile:

Like I just now specify where the overlays should go and it still doesn’t show and my scene doesn’t progress at all.

Here’s the updated part now:
@overlay GREEN MAGIC create
@overlay GREEN MAGIC shifts to 115 215 in zone 2
@overlay GREEN MAGIC scales to .087 .087
@overlay GREEN MAGIC opacity 1
@overlay GREEN MAGIC scales to 42 202 in zone 3

I don’t see anything wrong so I’m just going to take a wild guess and say maybe it’s to do with clearing the overlay. Usually I just leave the overlay opacity at 0, shift it around and put the opacity back at 1. Maybe that might work.

Okay, I’ll try now.

Yeah I just tried it and it still isn’t working

Use @overlay (OVERLAYNAME)2 create from (original overlay’s name)

E.G.

@overlay GREEN MAGIC2 create from GREEN MAGIC.

(Then, proceed with the normal spotting as it would appear in the scene)

Make sure the second overlay (Which is the same overlay. but just making a copy of the original one) has a different name than the original, like I added “2” to the overlay name’s end instead of using the same exact name again, which may result in errors. :kissing_heart:

Try:

@overlay GREEN MAGIC create
@overlay GREEN MAGIC shifts to 115 215 in zone 2
@overlay GREEN MAGIC scales to .087 .087
@overlay GREEN MAGIC opacity 1
@overlay GREEN MAGIC shifts to 42 202 in zone 3

Didn’t work

I just tried this and it didn’t work either

Try placing timers on the actions being done for the second overlay.

(e.g.)

@overlay (OVERLAYNAME) shifts to 100 100 in 0?

Otherwise, @Dara.Amarie? :kissing_heart:

Well I kinda found out the problem it was with

@overlay REVERSE opacity 0 in 1 then overlay REVERSE opacity 1 in 1 loop INFINITE times
not having & only thing now I have to swap the coding.

@Jeremy can you close this? I found the solution on my own.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.