Panning With Tappables Help!

Help? I was trying to do a pannable scene with tappables stuck to the screen, but when I try I only get the panning, but they’re no tappables.

1 Like

Where would the arrows lead? Also did you close the bracket of the last option?

Have you put this somewhere?

@overlay OVERLAYNAME create

The arrows are just to change scenes, yes I closed the bracket for the last option

1 Like

Yeah, its on top before the label

1 Like

Change scene or change zones? Because I see u made your screen pannable al ready!

1 Like

Yep that’s what I was thinking too. Do you mean like you change completely background or to cut to another zone?

Completely different background

1 Like

Can I see your entire script? I can’t find any issue in the screenshot.

The whole thing? :sweat_smile: It’s 3,614 lines

1 Like

Uhh that’s pretty long! I guess you double checked already…

Yeah, I was playing through it before I noticed- it’s weird idk what’s wrong either

1 Like

Have you tried changing @overlay with @ui in every command?

Do you get any errors?
Is it just 1 thats not working or all of them?
Are the labels and gotos name the same?

Just tried, didn’t work

Remove the zone from the shift command. Using “ui” makes the overlay stick to the camera and stays in the same place. You put the ui in zone 2, so it’s stuck in zone 2 even if you pan, so remove the zone

1 Like

No errors, all of them aren’t, yes labels & gotos match

Are the arrows meant to be overlays or UI? It looks like you’ve mixed both

1 Like

I wanted them to be tappable overlays that stick to the screen as the reader pans

Then do what Dara said here:

And also change @overlay LEFT ARROW opacity to @ui LEFT ARROW opacity