Please help me someone! - overlays

I’m stuck on an overlay scene. It may just be something small that I have done to make it not work, or I could’ve done it all wrong, I just can’t seem to fix it.

When I move the overlays, the layers don’t work, so the photo that’s meant to be at back is layered at the front. And vise versa for the one that’s meant to be at the front.


@zoom on 0 0 to 100% in 0
@overlay POLAROID3 shifts to 61 130
@overlay POLAROID3 scales to 0.012 0.012
@overlay POLARIOD3 to layer 3
@overlay POLAROID2 shifts to 32 111
@overlay POLAROID2 scales to 0.013 0.013
@overlay POLARIOD2 to layer 2
@overlay POLAROID1 shifts to 19 106
@overlay POLAROID1 scales to 0.017 0.017
@overlay POLARIOD1 to layer 1

readerMessage Tap the photo!

tappable “POLAROID1” {

"Lily's first day at home".

I remember how excited I was when mum and dad brought a little bundle of pink through the door.


&overlay POLAROID3 shifts to 43 117 in 1

&overlay POLAROID3 to layer 2

&overlay POLAROID2 shifts to 15 89 in 1

&overlay POLAROID2 to layer 1

@overlay POLAROID1 shifts to -232 99 in 1 THEN overlay POLAROID1 to layer 3 THEN overlay POLAROID1 shifts to -193 135 in 1 THEN overlay POLAROID1 shifts to 62 133 in 1

That is my script and I’d really appreciate some help as soon as possible please because I’m meant to publish this episode on the 17th!

Do you have any characters spotted on the same layers? Sometimes I have issues when I have a character on the same layer as an overlay.

Maybe try scaling and shifting the overlays in the background as well.

INT. BLACK - DAY with POLAROID1 to 0.017 19 106 at layer 1 with POLAROID2 to 0.013 32 111 at layer 2 with POLAROID3 to 0.012 61 130 at layer 3

Also which photo do you want to be on top? Because you currently have POLAROID1 at the bottom and POLAROID3 at the top.

I don’t have any characters in this scene.

At first, the order is POLAROID1 on top, POLAROID2 in the middle and POLAROID3 at the back, then when it shifts around, it goes POLAROID2, POLAROID3 then POLAROID1.

Oh my god I’m stupid I just realised.

1 Like

So you have them in the wrong order at the start.

Change POLAROID1 to layer 3, POLAROID2 to layer 2 and POLAROID1 to layer 1

Yes, thank you for pointing that out! I completely missed it. :joy: :grinning:

1 Like

No worries! Let me know if it still doesn’t work :smiley:

1 Like

Okay, thanks.

1 Like

It worked! Thank you so much for your help.

1 Like

Glad I could help! :blush:

1 Like

Closed: Marked as solved by Op @Mona_Mona :v: