Script Error “no matching }”


#1

Somebody please help! I have gotten this script error and I have no idea what is wrong!


If somebody knows what this is for… Please let me know :slightly_smiling_face:


#3

The choice part needs to be a line above the Yes I think


#4

Omg Thank you so much😂 some times I just do some dumb stuff like that


#5

Oh no :slightly_frowning_face: it still doesn’t work


#6

Same, I make mistakes like that all the time. Just part of being a writer on Episode :joy:


#7

This is true😂


#8

Oh I think you need to put it like this:
choice
}
“Yes” {
}


#9

Nope, still no luck


#10

No like this

example:

CHARACTER
–Dialog here–
choice
“Yes” {
stuff here
}
“No” {
stuff here
}


#11

I don’t use choices much, so I wouldn’t know :joy:


#12

Did it work @random_life?


#13

Do you guys think it’s a glitch because it looks correct to me


#14

Im confused did u try it


#15

Yes and it still doesn’t work
I can’t even play it out.


#16

Did the error change?


#17

Nope, still the same


#18

Can I see what u changed?


#19

I actually fixed it. It was quite dumb. I took out the @KITANA +1 and then it changed my “readerMessage” into “readermessage” when I had a capital in the first place. Then I saved it and added back the “@KITANA +1” and it worked. So I have no idea what was the problem.


#20

@Ryan or @Jeremy you can close this :slight_smile:


#21

Closing per OP request :v:t2: