“Stupid” questions that never get answered? Get The Help Here 2!

I’ve tried this but it still doesn’t seem to work. Here’s the copied and pasted script and a link to a video showing you what happens:
INT. FAMILY ROOM 1 - DAY with FAMILY ROOM SOFA 2
&speechbubble is 177 153 to 103% with tail_top_left
&cut to zone 2
&zoom on 484 99 to 148% in 0
&TOBY spot 0.956 249 -1 in zone 2 AND TOBY faces left AND TOBY moves to layer 4 AND TOBY is arms_crossed_angry AND GIANINA spot 0.983 89 -27 in zone 2 AND GIANINA faces right AND GIANINA moves to layer 5 AND GIANINA is arms_crossed_angry AND INAYA spot 1.118 151 2 in zone 2 AND INAYA moves to layer 7 AND INAYA faces left AND INAYA is rear
&overlay FAMILY ROOM SOFA 2 moves to layer 6
&INAYA walks to spot 1.919 69 -361 in zone 2 in 6 AND INAYA does it while walk_talk_happy AND INAYA faces left THEN INAYA is tinker_kneel_loop
&GIANINA walks to spot 0.983 173 -30 in zone 2 in 6 AND GIANINA does it while arms_crossed_angry AND GIANINA faces left THEN GIANINA is arms_crossed_angry
&zoom on 320 31 to 114% in 6
INAYA
Why are you guys even watching Cut Me Up Daddy?
I told you only to watch G rated movies.

    TOBY 
It was Gia's idea!

1 Like

Try this.

1 Like

The problem might be the overuse of & in your script. You should be using @ most of the time.

2 Likes

Thank you so much! This worked perfectly! :slight_smile:

1 Like

Probably a very stupid question😂 but what’s the difference between:
@CHARACTER is idle
and
@CHARACTER starts idle
(for example)
And when do you use “does it while”?

Read this guide, it tells you the differences

Script Symbols/Commands and What They're Used For

1 Like

How do I add the text banner to the top of the story… like authors use it when it’s like funny/dumb info

1 Like

readerMessage (thext you want to say)

1 Like

don’t use any @ or &

1 Like

thank you so much :purple_heart::purple_heart:

1 Like

np :blob_hearts:

This is messing me up… The camera shake and the moving of the characters works perfectly, but the minute they reach their spot, they stop doing the ‘emotions’ i want them to do for just a second, and then start doing it again, and that looks really weird… I tried putting in the emotions of different places, as you can see in the script, but that didn’t make a difference. How do i make them hold their emotions through the movement and camera shake?

You’re using the & sign for all those commands which means they are all happening at the same time. Use the then command if you want them to immediately do those animations right after walking

&AKILA walks to ------ and AKILA does it while — and AKILA faces right then AKILA starts react_startled_surprised
&LION walks to ------ and LION does it while — and LION faces right then LION starts holdwaist_give_idle_rear

Oh my god, it worked! I’ve never used the ‘then character starts ----’ before. Thank you so much!

2 Likes

Okay sooooo, my script is doing this weird thing. After it gets too the line where the looping happens, it doesn’t move on any further. Anything after that line doesn’t happen. I am using the web previewer, though. Not sure if there’s a glitch or if I typed something wrong. Here’s my script, hopefully someone can help me. :sob:

You must always use the & sign when looping an overlay. If you use the @ sign, your scene will not continue and will stay in that loop the entire time.

Okay, i’ll try that.

&overlay SCENE OVERLAY 1J shifts to 99 407 in zone 1 in 1 AND overlay SCENE OVERLAY 1K shifts to 99 407 in zone 1 in 1 AND overlay SCENE OVERLAY 1L shifts to 99 407 in zone 1 in 1 AND overlay SCENE OVERLAY 1M shifts to 99 407 in zone 1 in 1 AND overlay SCENE OVERLAY 1N shifts to 99 407 in zone 1 in 1 AND pause for 1 THEN overlay SCENE OVERLAY 1J shifts to 99 396 in zone 1 THEN overlay SCENE OVERLAY 1K shifts to 99 396 in zone 1 THEN overlay SCENE OVERLAY 1L shifts to 99 396 in zone 1 THEN overlay SCENE OVERLAY 1M shifts to 99 396 in zone 1 THEN overlay SCENE OVERLAY 1N shifts to 99 396 in zone 1

Can someone give me the code to loop this an infinite amount of times? I’ve tried but it says I can only loop overlays.

You can’t use “AND” for loops. You can only use “THEN”

Alright so mines complicated, I’m generally good at directing but for the life of me I can’t figure out why my character stops then continues… like Idk how to explain it but it doesn’t run smoothly and it won’t let me upload a screen recording… please help before I go crazy!!!