Sword prop not removing

So, I’ve had a few people send me screenshots of my story, and in those screenshots, there were times where I added a sword to a character, but they don’t seem to remove it, even though I put “@remove Short Sword Metal Silver from CHARACTER”. Script and screenshot is below.

Can someone tell me why “@remove prop from CHARACTER” isn’t removing the swords?

sometimes that glitches try doing it on your phone

I’ve tried it on my phone a few times. The swords seem to disappear like they’re supposed to, but if I exit my story and re-enter it, the swords appear again.


I don’t know, but maybe since your @remove prop from CHARACTER is next to a transition scene, for the next scene try to do @remove prop… again? Try it and see if it works.

chck the scene above it where you add the sword…I noticed something similar when I had the add command accidnetly twice for the same character…the remove was not working then - dunno if it is this but better check that oyu added the sword only once

I checked and I only put the “@add prop” command once.

Originally, I had the “@remove prop” command next to the outfit change command. I tried adjusting the script before, but I don’t think it worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.