Tappable overlay error PLEASE HELP

okay, it’s been SO long since my last post here and honestly, i was avoiding coming here as i searched the internet top to bottom for a solution to this. but alas, nothing!! so here i am. basically an error message pops up that states the following:

Expected CHARACTER or SCENE change.
Found “​NARRATOR” instead.
Did you forget to CAPITALIZE the name, or close the ( ) around the animation?

i’ve tried tabbing “narrator” to ensure it’s blue and i’ve tried pretty much everything anyone has suggested on past issues with this error. someone please help me.

here’s my script (i’m using two tappable overlays to determine whether the reader would like to skip or continue to read the chapter):

Hmm, everything seems in order… from what I can see.
Could you send the rest of your script from above the part you’ve screenshot?! Because it could be something else!

sure!

Usually I’d say: there needs to be dialogue before the choice, and that’s true for regular choices.
But after checking my own script, which has zero issues with the tappable… even though I didn’t have any dialogue directly above the tappable choice either,[as you can see in the screenshot below] I’m now confused about why yours isn’t working! :thinking:

You and I code a lot differently… so it’s difficult to spot errors within your script, due to your layout.

well, it’s definitely interesting to see the differences between our coding methods lol… but yes, as you said, this is very peculiar. thanks for your help though, i hope someone is able to help me!

1 Like

This isn’t really about the error, but your times seem a bit odd at 180-186. There’s doesn’t seem to be enough time for the overlays to all appear fully :thinking: It looks like they’ll take about 4-6 seconds to fully appear while the tappable choice is happening? Or maybe I’m not seeing it right

yes, so what is happening in that part is that the first overlay, AETERNUM (title of the story) is shifting away, the opacity is decreasing. at the same time, the two tappables are shifting upwards (from a downwards position) while the opacity is increasing, so the three overlays i suppose are overlapping (only the slightest), let me know if that makes sense or is what you are talking about

I get what you were doing now. So then you’d need to flip the signs of lines 184 and 186. Assuming all of those should be happening at the same time.

okay, so i should change the & to an @ and vise versa?

It’s 186 that confuses me, because the duration is 7.5 or so seconds, but it occurs after everything else, so it’d still be appearing during the tappable choice

Yeah, that way they all occur at the same time. Ampersands should go above the line you want them to occur next to, and, assuming you want this to happen before the tappable choice, use the @ for the second one

i understand what you mean now. i switched the symbols but the error message is still being displayed… man we might be here awhile

Yeah, I didn’t think that’d fix the error. But it probably avoided confusion in the future when you went to test it out

1 Like

Could you try copy and pasting your script here from line 180 to the end of the brackets?

&overlay AETERNUM shifts to 41 196 in zone 1 in 7.5 using easeout AND overlay AETERNUM opacity 0 in 2.5

&overlay READCHAP create AND overlay READCHAP opacity 0 in 0 AND overlay SKIPCHAP create AND overlay SKIPCHAP opacity 0 in 0 AND overlay LINE create AND overlay LINE opacity 0 in 0

&overlay READCHAP shifts to 32 104 in zone 1 in 0 AND overlay READCHAP scales to 0.172 0.172 in 0 AND overlay SKIPCHAP shifts to 55 104 in zone 1 in 0 AND overlay SKIPCHAP scales to 0.172 0.172 in 0 AND overlay LINE shifts to 45 111 in zone 1 in 0 AND overlay LINE scales to 0.172 0.172 in 0

@overlay READCHAP opacity 1 in 6.5 AND overlay READCHAP shifts to 32 163 in zone 1 in 7.5 using easeout AND overlay SKIPCHAP opacity 1 in 6.5 AND overlay SKIPCHAP shifts to 55 163 in zone 1 in 7.5 using easeout AND overlay LINE opacity 1 in 6.5 AND overlay LINE shifts to 45 161 in zone 1 in 7.5 using easeout

tappable
“READCHAP” {

    ​NARRATOR
You chose to read this chapter.

goto story

} “SKIPCHAP” {

    NARRATOR
You chose to skip this chapter.

goto end

}

Haha, exactly. If our coding was pretty similar I most likely would’ve spotted the error… because I find it easier to spot errors when the coding goes down in a column, rather than everything being tied up together! :joy::rofl:

And you’re welcome… I hope someone else who codes in a similar way to you, will easily find where your error could be coming from! :blush:

1 Like

well… i think i fixed it, but it doesn’t really make sense to me why it wasn’t working before. i removed the narration from inside each choice and just left the ‘goto ___’ and then put the narration where the labels actually were, and this worked. so, go me i guess!

So I was just playing with it on my own portal and I also got the error. Then I tried changing it to say one of my characters’ names and it worked. Then I changed it to NARR (CHAR) and it still worked. Then I removed (CHAR) and it saved again. So I’m really not sure why this error is happening. There may be some kind of bug with the NARRATOR command? I’m not sure, I’ve never seen this before

okay, that’s interesting, maybe ill just have to work with that for now and revisit it, i did just say that i fixed it but i didn’t actually. only one of the tappables is working, but thankyou! ill do this in the meantime :slight_smile:

That might be because of your overlays. Are they cropped so that their hitboxes don’t overlap?