Tappable Overlay's not Working!

Hi Everyone,

I am having such awful trouble with my tappable overlays. I followed Joseph Evan’s tutorial down to a T and have literally been altering the script for hours trying to figure out why two of my tappable overlays aren’t working, when the other one is and they have the exact same scripting.

The tappable buttons are all the same size overlay, and the borders of the overlay are exact to the size of the bubble.


So my ‘ROCK POOL’ tappable button works fine, but the WOODS BUTTON and CABIN isn’t working! It’s so frustrating. Here is the script.
For simplicity sake, I added in label’s instead of branching underneath.

Where would you like to go?

goto label rock_pool
goto label woods
goto label cabin


Somebody help! What am I doing wrong!? I’m not getting any scripting errors they just simply aren’t working!

Also, when I get onto the for example Rock Pool branch, (the one that actually works) is there a way that I can make the back arrow take me back to the home screen at any time, not just after I’ve collected the item from that scene? I’ve tried jumbling it around but the only way it will work is if you collect the item first, and then the arrow will activate. (if that makes sense!)

I did try that, and it gave my script errors :frowning: that’s why I put it in but it’s still not working :frowning:

I did think to change that, but the WOODS BUTTON isn’t working either :frowning: I’ve filed a support ticket incase.


So this is what happens if I remove ‘tappable’ from each one. I’ve tried enclosing it in brackets but that also isn’t working. On Joseph Evan’s tutorial, he lays it out exactly like this and has no issues, I just really don’t get it!

I FIXED IT YAY thank you!

It works like this!


1 Like

Moved to Directing Helps and Tips since this isn’t a bug. Make sure to check out our Forum Tutorial for more info about where to correctly create topics, and feel to PM me if there are any questions. :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.