Troubleshooting for a matching brackets error message (FIXED)

I made this if/elif/else loop inside a choice, and I got an error message on the line marked with ** saying I opened the brackets but didn’t close them. I counted up the brackets and I’m pretty sure I closed it at the start of the elif bit - can anyone spot what I did? This is just copy pasted with the dialogue taken out to make it easier to read.
I want it to go to dialogue 1 on the first and second time round, and dialogue 2 on the third.

label switchgame_recap
choice “Give me a summary”{

**if (switchgame_summarycomplete2){
goto switchgame_recap
}elif (switchgame_summarycomplete){
gain switchgame_summarycomplete2
gain switchgame_summarycomplete
goto switchgame_recap

Can you post a screenshot of your script?

You forgot the @ sign for the pause on line 948

ah thanks! weird that the error it gave me was totally different to that, but it worked. thank you so much!

Whenever you get the “missing bracket” error but all brackets are there, then the real error is inside those brackets. You just have to check for any missing @‘s, misspelled commands, or any other error within the brackets.

1 Like

thanks! thats good to know.

Closed: Solved. Thanks all!