Weird Overlay Problem


#1

I have found my own solution to this after messing with it for 15 or so minutes, but it is a weird, NEW problem that I haven’t had before, that I feel like shouldn’t have happened, and I’m still really confused, and I want to know WHY it happened, if that can even be answered.

I uploaded a new overlay. Nothing new, I’ve done that before. It was a full sized one, nothing new, I’ve done that before, (it was basically a chapter card thing I drew, so…). I put it in the script, nothing new. I previewed, it was fine, Showed up, no problems. Yay…

So…I wanted to put in a speechbubble at 0% so it could do a tap to continue type deal. First, when I did it, I got an error, saying “this speechbubble isn’t a thing, try one like this:” I thought, maybe it can’t be at 0%? That’s fine. No one can see a 1% bubble. Whatever. Nope. Still issues. I had one below at a normal position, so I copy pasted, I STILL GOT THE ERROR. I was like…??? Okay. No problem. Delete. I’ll figure it out after you finish your seizure. So, no more error message.

But, this time, I tried to view it, it told me I couldn’t preview a node that couldn’t be found? What…? I’ve never gotten that message before, it was bizarre, and I couldn’t click anything in the previewer after that. So I refreshed, no problem.

After that, I can review it as normal. Except…the Overlay was this white, blurry mess…all of a sudden, like just a second ago, before a speechbubble problem, there was no problem. And the speechbubble was gone, so if they were connected, it shouldn’t be a thing…? But it was? I opened it up in my phone to see if it was doing it, too. And it was.

I thought for just a second, and then I started to zoom out. A lot. I had to sit there and zoom out for like 2 minutes cause I had a suspicion that it was zoomed in really far, even though I did nothing with the zoom. At all. It was showing up just fine before. And no other overlay I’ve uploaded had done this.

Just for a test, I put in an overlay that was Episode-made. Not one I uploaded. THE SAME PROBLEM! I was livid. BTW, there was a &zoom reset the whole time, so that’s not an issue.

So, I just zoomed and zoomed and zoomed out, before I realized, I could just mess with the camera zoom instead. So I did that. I had to zoom ALL THE WAY OUT AT 0% to see the frigging thing. ALL THE WAY! WTF?? Fine, whatever, that’s cool, right? I figured it out.

BTW, you can’t have a 0% zoom, so it’s actually at 1% and I changed the overlay accordingly, but now it is there. No problems. You know what else?

I put in a speechbubble with all 0 values and that’s perfectly fine now.

So I wanna know why this bizarre thing happened. WHY. LOL! I am so confused XD


#2

Well, idk much but I think if the value is above 0%, you need to shift/scale it.


#3

Which thing? The Overlay? It’s not at 0%, it would have disappeared completely. It was at 1, and it was never changed.

I wanted the speechbubble at 0%, and that’s doable.

And the zoom will just be black if at 0%. It had to be at 1% to show the overlay. XD And then I had to scale the overlay after that. I don’t remember by how much, though. I could look, but I don’t wanna mess with it anymore until after the overlay gets approved in a couple days. Maybe I’ll mess with it some more then and see if it happened because it needed to be approved before it functioned like a normal overlay. I doubt that, but anything is worth figuring out.

It is honestly probs something to do with the recent update. There’s a lot of glitchy nonsense going on right now. Like the load node story cannot be found thing.


#4

So whats the problem you are having?


#5

Was* having. This is more like, if anyone else starts having a weird thing with their overlay, this is how I fixed it.

The overlay was blown up way to much after the node error, then I found the easiest way to “fix” it, so it fit on the screen. By making my camera zoom to 1%

I just thought it was important to share the whole story, any details could have set it off.

(sorry if I irritate you)


#6

There’s just a general abnormality with overlays. I know how they’ve worked in the past and I know how they’re supposed to work, but they got me all sorts of shook rn.

I had another overlay I created. When I put it in the script, it was fine forever. I changed the overlay to something different because of reasons, it doesn’t matter, I needed to. After I changed it, just pasted the correct one in the place, it wouldn’t show up on my phone previewer, and it said it didn’t exist even though this was the format:

BACKGROUND - DAY with overlay_name
&overlay overlay_name shifts to x y in 0

It didn’t exist, so I put it like this instead

BACKGROUND - DAY
&overlay overlay_name create
&overlay overlay_name shifts to x y in 0

It still didn’t show up, but I didn’t get an error message.

I switch the overlays back again, and there the old one was. LOLOLOLOL!

So…I closed it. Opened it. Changed it to the correct overlay again the first way,:

BG - DAY with overlay

and then…there it was in the browser previewer. So I took my phone, reset progress, skipped to navigation ch and scene, and there it was. Good as new. XDXD

What?