What is the problem with those layers?


#1

@1 walks to screen center
@2 moves to layer 0 AND 1 moves to layer 1
@1 is hug AND 2 is hug_rear AND 2 faces left

The boy (2) is behind the girl (1)
I tried switching the layers, but that didn’t helped!


#2

The layer 0 is behind the layer 1. You can try to change your layers.


#3

See the change I made!


#4

I don’t know then… It was supposed to work :sweat_smile:


#5

Can you send a picture of your script?


#6

Try changing the layer 0 to 1 and layer 1 to 2


#7

I can try that, but I have use 0 and 1 before :thinking:


#8

Sometimes it just seems like that…
what are you previewing it in…
the web previewer or the app previewer??


#9

Web, but I am writing with someone so I don’t have the app previewer, only the shared version! But in the shared version it is wrong as well!


#10

Sometimes the web previewer seems glichy and previews it wrongly…
say to that person that you are writing with to check it on her app…


#11

See the change!


#12

So have you checked it with the app one as well??


#13

Well, I checked it in the app with the share link!


#14

Then try changing the layers to negative numbers…


#15

Didn’t helped either!


#16

Then try the move command separately for both characters like this-

&2 moves to layer 0
@1 moves to layer 1


#17

Didn’t worked either…
I really need this fixed…


#18

What could be the issue then??
These layers works and maybe there is an error in your script somewhere else or its a glich as I tried this and it works perfectly fine for me…


#19

Well, it is within a choice, and the hug is in both of the options, in the other one it works perfectly fine…


#20

If it works fine in the other try changing that part where they hug each other with the part that works fine…
As I have this problem I just replaced a sign in my script and then it worked…