Writer Payment: Sign up bug (blocked by extension)

I recently unlocked the Writer Payment and was asked to add my payment information upon signing up. Now the following error occurs, whenever I load said page.

I have tried several browsers (Opera, Safari, Chrome). I have cleared my cache. I have logged out and back in.
I tried with and without browser extensions.

Then I checked the forum and saw that this had been reported to you back in August and was closed without solution. Payment's section blocked by extension (I need help) Contrary to what is written on the answer to this posting, this is NOT an app issue. It is a bug on the writer portal in the Payment section.

I’ve filed a ticket and received a generic automatic answer once again, which asked me for a screenshot and details I had already attached to my ticket in the first place. So, I went and talked to some other authors and have gotten feedback from more than one person that they also experience this issue and that you should have received several tickets about this by now, of which not a single one has been answered with a satisfying solution.

That being said, I would really appreciate a quick solution because it kind of leaves a bitter taste if this is how you treat creators who worked hard to get into the program you offer. If you need more time to fix this, please let us know and offer us a manual workaround for the time being (e.g. let us send the required details to a person who adds us to the database manually.)

Thank you.


In the same boat. Been waiting two weeks for a response, have even filed a separate ticket as all previous emails have been ignored.


I have heard from other creators who can’t change their payment information


Mine looks like that too. It hasn’t been an issue for me, but it’s been like that for a couple months now. I can’t access my transaction history either.

@Arrows.Episode and @thebutterfly_episode Have you tried directly emailing the email in the FAQ section? (It’s like payments@episodeinteractive.com) ? Maybe that might be more useful? (Although it’s probably the same support team for all I know lol).


Thank you for the tip! :slight_smile:

Can I ask you, how you are handling the payment info then?

Also, I don’t really want to open yet another ticket, just to receive the same answer I seem to get on any ticket I put: “Could you please provide the information you have already provided in your initial ticket but we didn’t even look at because we have SLAs that are kind of killing us right now, so we just quickly reply with a message template to everything we receive and then sent another email 2 weeks later, stating that we could not get back in time to you and are sorry. But we will be closing this ticket now.” xD (Sorry for the sarcasm but it’s the nicest mood I currently have to offer.)

I was in the program before those sections went weird and haven’t needed to change my details.

Yeah, I’ve given up with support tickets recently. It’s always a generic response that doesn’t answer anything then after you reply you don’t hear back for at least a week and then it’s the generic “Due to an exceptionally high support ticket volume, we were unable to respond to your support ticket in a timely manner, and we sincerely apologize for the delay in our response.”

I just wondered if emailing that email might send it directly to someone on the payments/finance team? (I just checked my emails- when my information was updated in the system, that’s the email address I was told to email if that was unauthorised. It could be the same team but maybe there are also dedicated payroll people who would get the email first and might be able to help you?)


Thank you so much for your help! I hope they’ll actually solve this or offer a workaround for the time being :slight_smile:


I’ve emailed them directly three times, generic responses every time and then ignored for weeks. I just received another generic response last night that another friend received 3 weeks ago about this being escalated to Jesse, but nothing since. V frustrating!


I’ve only had to email them directly once (about payments but a different issue) and it was escalated to Liz- the day before her maternity leave :roll_eyes: I did think “What’s going to happen when she leaves” and I guess we have our answer…
Definitely frustrating! I really hope someone gets back to you guys soon :expressionless:

1 Like

Update: I got the generic email, as predicted:

Only, it was one week instead of two. But the result stays the same. No solution.

1 Like

I was told a week ago that this was being escalated to @Jesse who would be in touch shortly. Have heard nothing since and having spoken to other creators in the same boat they received the same email over 3 weeks ago. I’ve filed a second ticket regarding this but am not sure what else I can do at this point? Feeling very dejected.

1 Like

Just had one of my tickets closed… no formal reply was made to it, other than to tell me that their response time was delayed and then it was just closed.

Feeling extremely frustrated right now…


I submitted one as well as I figured multiple tickets about the same issue from different people couldn’t hurt?
Anyway, after one week since I sent the first ticket, mine has also been escalated to Jesse but based on your responses, I’m not holding my breath lol.


I have just been notified that it’s being escalated to Jesse … Seems like we are all going down the same path here.

I’m experiencing the same issue and it kind of annoys. I’m almost three years on Episode and finally I’ve received this opportunity, but I can’t sign up for this payment section. I submitted several tickets but received the same responses as you are…I did it one more time just a few minutes ago, we’ll see…But Idk what else to do…


I guess, it’s waiting now … I also felt excited when I finally unlocked it. But at least it’s unlocked, right? :smiley:

Lol, yeah​:sweat_smile::see_no_evil:

1 Like

I got a very useful tip from @Lillys , which helped me open the page in a different way. It seems that Episode is using a payment provider for payment handling. All pages which are connected to this payment provider (“Tipalti”) are loaded inside an iframe on the page. And this iframe does not work anymore or has been embedded in a wrong way.

From my pov this should actually be a rather easy thing to solve. But in the meantime, you can access it through opening the iframe’s URL in a new tab. I will go ahead and provide this info to the Episode support team/Jesse if he ever gets in contact.

Here is how to do it in the meantime:

  • Open the page containing the error (preferably in Google Chrome)
  • right click on the frame (the grey thingy with the sad face)
  • choose “inspect”
  • A window will open that shows you the CSS from the page
  • scroll up a little inside this new window and you will see a URL, starting with the name of the provider https://tipalti…)
  • Right click that URL and select “open in new tab”
  • The payment sign-up form will now open in a new tab
  • To get to the “next” button on the form, use CTRL+minus to zoom out inside the browser window

That’s it.

@Admin: Please do NOT close this topic! The bug has not been resolved. A user just found a workaround.

Thank you!


I just got a reply from Jesse telling me to try signing into Tipalti directly. So far I haven’t been able to do this although I’m not sure if I’m just using the wrong password or something lol (I tried clicking on “forgot password” but I never got an email so I don’t seem to be registered).

I sent an email to Jesse yesterday, explaining the workaround and the the issues I therefore assume would be relevant to look into. He got back to me rather quickly this time, also sharing this link.

I am afraid though, that this link is a login for customers of Tipalti, which we are not. In this case, Episode is the customer of Tipalti and therefore I don’t think we will be able to login with our episode credentials (otherwise this would mean, that our login has been shared with a third party provider without us knowing which does not really make me feel comfortable. Then again, I live in the data protection country #1 :stuck_out_tongue:, so that could just be me)

I have provided screenshots now and all insight I could gather, hoping that it may help to solve the issue.

At least we are one step further :slight_smile: