Filter glitch in preview?

the portal isn’t letting me add any filters in my preview. when i do turn them on, it gives me a code like “@set hsl 0 0 0 no_colorize with blendMode <MenuItem | tag = -1> to 0%”.

any way to fix?

1 Like

It’s not a glitch, the problem is because of two things:

  • You need to remove :point_right:t3: <MenuItem | tag = -1>
  • And you need to add whatever the tag for your preferred filter is.
    You add this between the words “blendMode” and “to”.

For example, if you want the luminance filter, and you want it at level 50%… then the code for that would be: :point_down:t3:

@set hsl -13 -48 -76 colorize with blendMode ADD to 50%

But I’m not sure why it gave you a filter set to 0%… because 0% wouldn’t show at all.


fyi: the setting on 0% is because this “glitch” shows opacity on 0, earlier when it wasn’t like that opacity was on 100 all the time from the start, so you could basically see the changes immediately; now you need to change it manually to 100 and then adjust it to your liking.

The first time it was in the app was a few months ago (maybe even a year ago; I remember sending a ticket about it), and they never fixed that issue (some people have it, some don’t), it also showed etc, now it’s in the web preview as well, but at least you can change the coding to make it work. :smiling_face:

The last time this happened to someone, their % was 41%… but personally, I never get this “glitch”.
Filters always work properly for me, and I never have to change anything! :woman_shrugging:t3: But either way… the method I gave, fixes the issue.

Thanks for working through this HSL issue together as a team!

We wanted to follow up and let you know that we’ve released a fix for the Filters tool so that it will include the proper blendMode instead of the erroneous <MenuItem | tag = -1> output.

Do let us know if it’s still not working. Thanks!