Unexpected block end Points System

I’m trying to use the points system. For some reason, I keep getting the “Unexpected block end” error and I don’t know why. This is what it looks like.

set format phonetext

Hi, Sebastian


Hi, gorgeous.
Is it too soon to say I miss you?

I think so lol.
You said you were going to call.
What changed?

My roommate just got home.
He had a really bad day. I don't want to make it worse by being too loud.

Where have you been all my life?

In my room, patiently waiting for the day I meet you.

Looks like that day is today.

It is.
I can't wait until I see you again.

Me too.
I've got to go. I'm exhausted.
Talk soon xoxo.

Sweet dreams.

} elif (SEBASTIAN <3) {

I didn’t think you were this interested.
I can’t talk now.
Will text later.

} else (SEBASTIAN <2) {

Can’t talk.

Does anyone know what I’m doing wrong?

These are the situations where I assigned points:
When I add a point for a choice “@CHARACTER +1,” for the other option of the choice do I have to subtract a point also"@CHARACTER -1" Am I supposed to assign a certain point at the beginning of the story, “@CHARACTER =2” so there’s something to add to and subtract from when I code in the points?

Try removing the (SEBASTIAN <2) the else doesn’t have conditions :blush:

With else you don’t need a condition, so just

} else {

It still doesn’t work

It still doesn’t work. I’m not sure why. It should, right?

Also here, if needs to be all lowercase

if (SEBASTIAN >2) {

does the error point on specific line of the code?

The conditions inside your if commands are clashing one another.
There’s a condition for greater than 2, less than 3, and less than 2.
You should use = for the middle value, and greater/lesser for the greater and lesser value respectively.

1 Like

I don’t know why I didn’t see that. It worked! Thank you.

1 Like

It was the elif line. That wasn’t where the problem was though. Weird.

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.