Character Spots Glitch

I’ve been having a glitch where I’d assign two characters to a certain spot but they end up in a spot I didn’t direct them to. Is there any way I can solve this?

1 Like

Can I see part of your script where you are having issues?

wait, are you in zone 1 already

I put Anita and Jacinta in zone 1 but zoomed out being in zone 2 and they were in a different place

are you trying to zoom out


So you are not trying to zoom out

I think maybe you spotted them off camera.

Here is a thread I did that could help.

I didn’t. I spotted Jacinta at 0.894 -34 94 but she stood at 0.894 -354 94

I see what she is saying. When you zoom out like that it does look like it is not placed right. What does it look like when you are correctly zoomed in zone 1?

I put @cut to zone 1 and they are still in the spots they shouldnt be in

1 Like

Ok so your spot numbers are wrong.
I tried it and this is what I got.

I changed their spots and now they’re in the places they should be thanks! C:

And now it’s happening again, great

1 Like

Glad you fixed it.

You were using negative spots. Therefore, they wouldn’t be in the zone.

When you assigned their spots, did you assign it from zone 1 or zone 2?

Zone 1

What are the coordinates of your current error?

@ANITA spot 0.926 7 81 in zone 1 AND ANITA starts talk_apathetic AND ANITA faces right AND ANITA moves to layer 1

@JACINTA spot 0.894 62 87 in zone 1 AND JACINTA starts listen_nod_neutral_loop AND JACINTA faces left AND JACINTA moves to layer 2

then a few sentences later

@CARLOS faces left AND CARLOS walks to spot 1.202 215 22 AND IRIS faces right AND ALEJANDRA faces left AND ALEJANDRA walks to spot 0.937 156 111 AND ALEJANDRA moves to layer 1 AND ANITA moves to layer 3

Alejandra isn’t in the spot I directed her to but I click on her it’s the same numbers as I coded but for Jacinta it says 0.894 -258 87 which is not what I put
And for Anita it’s 0.926 -313 81 which is not what I put